cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AmitLoh-Powerap
Kudo Kingpin
Kudo Kingpin

on premise gateway fails when form based or sts auth is enabled along with windows auth

on premise gateway fails when form based or sts auth is enabled along with windows auth.

 

7 REPLIES 7
v-micsh-msft
Community Support
Community Support

Hi @AmitLoh-Powerap,

 

Could you please sahre more information about the "form based or sts auth is enabled along with windows auth" here?

With which data source that you enabled this kind of authentication, and for what usage?

Basically there is no need to enable authentication under Microsoft Flow side, the account information needed for authentication is verified when adding this connection under gateway, and will be stored with the gateway connection.

For the errors, could you please check the error details first through the gateway logs?

Understand on-premises data gateways or Microsoft Flow

Please refer to the troubleshooting part mentioned in the article above.

Please post back if you need any further assistance.

Regards

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

In sharepoint central admin under authentication section please try sts or form based auth along side windows and check if gateway works(it does not). There are many scenarios(SSO, form based where STS and form based auth is required).

Many onpremise implementations have SSO or adfs based sso or sts based sso in place at web app level. This gateway does not work in these scenarios and flow can not be used in those scenarios as of now. It only works when you have windows authentication is in place which is not every sharepoint project scneario.

Hi @AmitLoh-Powerap,

 

Thanks for your update.

For SSO enabled on-premise data source, when choose using the gateway, would it be possible for you to enter the 

"

Oauth2

"

Under authentication type?

 

I tried with my testing account and specify the authentication type as 'Oauth2', the connection created successfully under Microsoft Flow.Sorry to say that currently I don't have available on-premise SharePoint data source to perform a test, I can't confirm whether the connection would work. If convenient, please take a try to type the oauth2 in Authentication type, then create the SharePoint connection, see if this would make it work.

For PowerApps, currently SharePoint on-premise only supports the Windows authentication (A dropdown with 'Windows' choice only).

Regards

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

hi @AmitLoh-Powerap!
Could you help us clarify your scenario:

Are you trying to use the gateway with sts auth connection? or are you trying to use Windows auth with the connection while having sts auth enabled on your SharePoint site? 

Thanks in advance!
Dimah

Great question!. I am trying to use windows auth when sts is enabled. I need to use either of the 2. Gateway works only when only windows is enabled. I think the sts/windows selection dropdown when sts is enabled in default kills the authentication. Please fix this.

Got it! Thanks for clarifying. We'll look into this! 

There's no solution yet to this matter?

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,199)