cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
akharns
Level 8

"Error executing the API" on File System connection

I'm trying to get a first step connection working with Flow using the File System.

- I created a top-level folder on my local machine (c:\testfolder) and dropped a couple of files into it.
- I created a connection called "local-test".
- For Root folder, I used \\mymachine\testfolder. I assume that my machine can be accessed through the company gateway.
- For Authentication type, I used Windows.
- For Username, I entered my domain\username. I have also tried the format username@domain.
- For Gateway, I used a gateway that I have successfully used from PowerApps, though I was connecting to SQL, not my local machine.

 

It seems that an error flashed (too quickly to read). When I go back in, it didn't save the username.

 

The result is that, when trying to select a folder in File System in an Instand Flow for "List files in folder", I get "Error executing the api".  I expect I set up the connection incorrectly, or the Gateway was set up incorrectly.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Community Support Team
Community Support Team

Re: "Error executing the API" on File System connection

Hi @akharns ,

 

Yes, I afraid that there is any wrong for the connection or Gateway, please check the connection and Gateway.

 

2.png 

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

akharns
Level 8

Re: "Error executing the API" on File System connection

Thank you.   I had listed the domain incorrectly in the connection.

View solution in original post

2 REPLIES 2
Community Support Team
Community Support Team

Re: "Error executing the API" on File System connection

Hi @akharns ,

 

Yes, I afraid that there is any wrong for the connection or Gateway, please check the connection and Gateway.

 

2.png 

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

akharns
Level 8

Re: "Error executing the API" on File System connection

Thank you.   I had listed the domain incorrectly in the connection.

View solution in original post

Helpful resources

Announcements
firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users online (4,409)