cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate III
Advocate III

"Network Error" in Google Drive 'List Files In Folder' Connector

Hi

 

I'm getting a "Network Error" in my free flow account (that's way below the limit of flows run) that is connected to a Google Suite account which is trying to simply list files in a Google Drive folder. No other error is given.

Network Error.jpg

The only connector action being run is to list the files in a google drive folder defined by the folder id.

 

This is a cloud to cloud connection, and I believe that the below indicates I've tried it from every angle. It shouldn't be a Network error, if it's anything ... so I'm a bit confused, what's going on?

 

Further information

  • The connection that it uses worked 3 days ago.
  • I've checked 'Review connections and actions' and it's fine:
    Network Error 2.jpg
  • I've created a new connection for the connector. Still doesn't work, "Network error."
  • I have imported it into a paid account where it does not get the Network error at all where. It works.
  • I have recreated the function in a separate free account with a different Google Suite account. It works.
  • I have tried creating a flow with another Google Drive action (Create file) on this account. Doesn't work, "Network error."
  • I've made a new flow to try the same thing with either connection. Still doesn't work, "Network error."
  • I've searched these forums for "Network error" and nothing useful popped up.
  • I'm about to test this from another PC, in case this is some, weird, cookies issue. Will edit with results.
  • I have no script blocking running.
  • Using the latest version of Edge DEV.

What's going on here, has anyone experienced something like this?

 

1 ACCEPTED SOLUTION

Accepted Solutions

I thought that this had resolved itself, but it hasn't. It was working for a couple of days, but now it's back to nothing. Again, I can't raise a support case for this as the account is free, and my paid account is a separate one.

 

Again:

  1. I've made a brand new flow, from scratch, with a cognito forms trigger, and a google suite action.
  2. I've tried with multiple DNS providers, home IP, VPN IP, and still nothing.
  3. I've exported it to my paid account, and it's fine on home IP, multiple DNS.
  4. I will export it to a different free account ... results tbc.
  5. I'm getting NetworkErrors when I try to run the flow, and within the Google Sheets action I get a "Failed To Fetch" error pointing me here: http://aka.ms/PowerAutomateFailedToFetch
  6. I tried completely removing the connected actions that run in the flow, and it STILL gives a Network Error ... despite there being absolutely zero connections in it. And, again, it runs fine, literally in another browser window, on the paid account.
  7. The only thing I can't change is the actual connections existing in the Flow details screen because (again) I'm not using a paid account.

Both connections show as a nice green tick, though. So they are connected.

 

I will, again, try running the same flow from another computer and on another ISP entirely. But this is getting old, fast.

 

Edits will come.

 

If it looks like I'm not giving much on #5, you can use logic to see that there's clearly nothing on the network stopping me from browsing those sites as they load in the other browser window.

 

EDIT

Found the Issue:

 

The browser user that is running the problematic account in Edge has a script blocker installed, and it wasn't allowing all of the domains required to run it.

 

Once those domains were listed for that user, then it runs fine.

 

Luckily that user is purely for one profession and there's no cross-section because some of the Microsoft domains that are required are found elsewhere online, and I wouldn't want that kind of privacy invasion on a personal browsing session.

 

If you use a script blocking add-on or extension for your browser, make sure that it's set to allow the domains that are listed in the URL above.

View solution in original post

3 REPLIES 3
Microsoft
Microsoft

Hi @eliotcole ,

 

I just created a connection and a flow and ran with no problem, also using a trial license. Can you retry the operation, perhaps was an intermittent issue?

 

If you do still have the issue try to check the network trace and see if there is anything blocking it. Also try to create a new folder and upload a test file inside, see if the same issue happens with the new folder.

 

Let us know the outcome.

Hi, @danielbazetto , whilst I'm happy that you're able to do this without issue, it's still a problem for me.

 

This is now on a different computer than the one before.

 

This cannot be a network trace issue, because (as I mentioned, I believe) this is a cloud to cloud operation occurring from a cloud application (that we're discussing within the forums of which), from multiple browsers that have successfully managed connecting to the same source literally seconds before or after this fails to work.

 

There is no reason for network connectivity to be an issue here.

 

I also get a "Failed to Fetch" when I tried to create a "Send email" action using Gmail.

 

It's also giving me some strange errors with my Cognito forms connector if that's related.

 

Oh, and in case it was a thought process ... when trying to contact support it directs said account to this forum, because it is clearly not a paid account.

I thought that this had resolved itself, but it hasn't. It was working for a couple of days, but now it's back to nothing. Again, I can't raise a support case for this as the account is free, and my paid account is a separate one.

 

Again:

  1. I've made a brand new flow, from scratch, with a cognito forms trigger, and a google suite action.
  2. I've tried with multiple DNS providers, home IP, VPN IP, and still nothing.
  3. I've exported it to my paid account, and it's fine on home IP, multiple DNS.
  4. I will export it to a different free account ... results tbc.
  5. I'm getting NetworkErrors when I try to run the flow, and within the Google Sheets action I get a "Failed To Fetch" error pointing me here: http://aka.ms/PowerAutomateFailedToFetch
  6. I tried completely removing the connected actions that run in the flow, and it STILL gives a Network Error ... despite there being absolutely zero connections in it. And, again, it runs fine, literally in another browser window, on the paid account.
  7. The only thing I can't change is the actual connections existing in the Flow details screen because (again) I'm not using a paid account.

Both connections show as a nice green tick, though. So they are connected.

 

I will, again, try running the same flow from another computer and on another ISP entirely. But this is getting old, fast.

 

Edits will come.

 

If it looks like I'm not giving much on #5, you can use logic to see that there's clearly nothing on the network stopping me from browsing those sites as they load in the other browser window.

 

EDIT

Found the Issue:

 

The browser user that is running the problematic account in Edge has a script blocker installed, and it wasn't allowing all of the domains required to run it.

 

Once those domains were listed for that user, then it runs fine.

 

Luckily that user is purely for one profession and there's no cross-section because some of the Microsoft domains that are required are found elsewhere online, and I wouldn't want that kind of privacy invasion on a personal browsing session.

 

If you use a script blocking add-on or extension for your browser, make sure that it's set to allow the domains that are listed in the URL above.

View solution in original post

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Top Kudoed Authors
Users online (3,469)