cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ryanBourbon
Frequent Visitor

updating a row in excel

Hello,

I am having issues updating a row in an excel table based on a conditional.  My intent is to go through a table of values and check to see if any item is not "processed" and if it is not, I will send an email and then mark that row as processed by placing an "x" in the column.  I can iterate through the table and send emails just fine but the flow errors out each time I try to update the row.  I have included a picture of the table as well as the flow.  Thanks for the help!

 

Ryantable.JPGupdateRow.JPG

4 REPLIES 4
DamoBird365
Community Champion
Community Champion

@ryanBourbon 

 

What's the error?

 

Damien

ryanBourbon
Frequent Visitor

Hi Damien,

The error I am getting is that the row is not found.  This is strange to me because if I look at the inputs section of this function it shows that it is on the right row but then in the output it states it does not find it.  I have included a picture.  

 

Thanks!

 

RyanupdateRowError.JPG

Hi @ryanBourbon 

 

You are passing a whole object to the key value when I guess it should be a string?  Look at the key value in your screenshot.  It's in curly brackets.  In order for the action to know which row to update, you need to supply it with a column name and the key to filter on like a unique ID.  Looking at your sheet, maybe that would be your employee ID or date of entry and not the Processed Column as this is the column you want to update, not search by.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Cheers,
Damien


P.S. take a look at my new blog here and like & subscribe to my YouTube Channel thanks 😉

I assumed the flow would know the row because it is within the loop based on a condition.  I have added a function to email within the same section and the email goes through properly.  I have changed the key column and key value to the point that it will not fail but it also does not function.  I am wondering if it is the general method I have used to set this flow up and if there is a better way.

 

Thanks,

Ryan

flow.JPG

 

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (2,189)