cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
ReganMarkwick
Level: Powered On

Combo-box Empty on iPad unless run in classic mode

We have a combo-box which is populated with a number of values from a Collection. On Windows the content of the Combo-box loads successfully, however when we run via an iPad (latest version of powerapps) the Combo-Box is empty.

 

We set the render mode to 'Classic' and this resolved the issue however we recieved a system message when opening PowerApps that 'Classic Mode' will be going away soon. This is troubling as we plan on rolling our app out to 20+ users via iPad.

 

The message is: Improved app rendering is now even better and will soon replace classic rendering. Please try it again and let us know what you think.

 

Most collections are populated like this:

 

If(Connection.Connected,
ClearCollect(CountryLocalListCollection, ShowColumns(Filter(Countries, statecode = 0),"new_countryid", "new_country", "new_nationality","statecode"));
SaveData(CountryLocalListCollection, "CountryListLocal");,
LoadData(CountryLocalListCollection, "CountryListLocal", false);

 

This is using CDS to connect to a Dynamics 365 datasource, but I assume doesn't matter as the combo-box is ultimately loading the local collection.

2 REPLIES 2
Community Support Team
Community Support Team

Re: Combo-box Empty on iPad unless run in classic mode

Hi @ReganMarkwick,

Where do you put your Collection formula within your app? Within the OnStart property of the first screen of your app?

I have made a test on my side, and don't have the issue that you mentioned.

Please check if the Network state is in good condition within your iPad device. Also please check if the version of PowerApps Mobile App in your iPad device is the latest version, if not, please consider upgrade it into the latest version, then try your app again to check if the issue is solved.

In addition, currently, within PowerApps, there still have something issue with "Improved app rendering (final validation)" option. If the issue occurs within your iPad device, please consider take a try to turn off/disable the "Improved app rendering (final validation)" option within your app settings and turn off the "Delayed load" option within Advanced settings of App settings of your app.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
ReganMarkwick
Level: Powered On

Re: Combo-box Empty on iPad unless run in classic mode

Hi Kris,

 

I've tested the application on an iPad, iPhone X and Windows. The issue only occurs on the iPad when Improved app rendering (final validation) is enabled (as mentioned in my original post). Based on other posts this appears to be an issue with PowerApps itself. As well as the delayed load option.

 

We are running 3.18114.16 on all devices. Is this something that will be fixed in the near future for the improved rendering mode?

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Top Community Contributors for July 2019

Top Community Contributors for July 2019

Let's thank our top community contributors

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

FifthImage

Dynamics 365 and Power Platform April 2019 Release notes

Features releasing from April 2019 through September 2019!

SixthImage

Power Summit Australia 2019

August 20-23rd 2019

Users Online
Currently online: 191 members 4,627 guests
Please welcome our newest community members: