cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Gaëlle
Level 8

DatePicker control : Calendar not showing anymore - Need help !

Hello everyone,

 

I am stuck with one mother of a problem :

My DatePickers are not showing the Calendar anymore !

 

What I have :

I have created a carpooling application. I have set 3 DatePickers throughout my application.

First one is supposed to be a filter on the BrowseGallery screen. It is filtering Items on one Date field. I've added it through "Insert" tab > Controls dropdown > DatePicker and is set to

Second and Third one are DataCards from my Sharepoint List. They appear on the Edit and Detail Screens.

 

What is my problem :

When testing my app, I click on the little calendar icon. normally that action should display a mini calendar to pick a date, but it is not showing anymore. I can still enter a date in the text field, and when i save, it is well saved in my SP List.

 


What i tried:

Because i've customize my three datepickers, I've tried to simply add one "normal", from the Insert tab > Controls > DatePicker.

Just that, no customization. If I launch my app and click on the little calendar icon, nothing happens either.

 

 

So, my problem is really graphic, because users expect a datepicker to show a calendar ! It is tragic, because i've just noticed that and i have to send my app to production on thursday, i'm kind of a bit stressed right now.

 

Do you know why the calendar is not showing anymore on the date picker? Is it a PowerApps problem ? Or is it coming from my app? Can you help me please?

 

 

 

2 REPLIES 2
Community Support Team
Community Support Team

Re: DatePicker control : Calendar not showing anymore - Need help !

Hi @Gaëlle,

 

Could you please share a screenshot about the issue in your app?

 

I have made a test on my side and don't have the issue that you mentioned. The GIF screenshot as below:Test1.gif

 

 

Please take a try to re-create your app and add a Data picker control within it, then check if the issue is solved.

 

In addition, please take a try to run your app on PowerApps Mobile App, then check if the issue still exists. 

 

Please also consider take a try to clear cache of your browser, then try your app again to check if the issue is solved. Please make sure that your network is in good condition.

 

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Gaëlle
Level 8

Re: DatePicker control : Calendar not showing anymore - Need help !

Hello @v-xida-msft !

Thank you for your time,  I don't understand what is happening.

Here are two screenshots from my solution :

- I added a new DatePicker without any customization, it has all the default values (like DefaultDate is Today()), and DisplayMode is Edit. Here it is on my BrowseScreen1 (my other datepicker are a bit customized, but normally everything should work fine):calendar01.PNG

 

- Now, I run my app, and click on the little calendar icon . You can see there is no big difference, just the little icon has a dot line on the left side. The calendar does not show up.calendar02_clicked.PNG

 

 

 

 

This is, unfortunately, all i can show, because there is nothing to see, really.

 

I tried to add a default DatePicker on each of my screens : BrowseScreen1, DetailScreen1, EditScreen1 and BookingValidationScreen. Everytime it is the same, the default datepicker with DisplayMode.Edit is not showing calendar.

If I try to run Developper Tools when running my app, I have 2 warning saying :

- "Error in source links : request failed with status 404

asset URL : https://cdn-paaprodweu.azureedge.net/v3.18064.24.80921456/studio/openSource/modified/winjs/js/base.j...

Source Link URL : base.min.js.map"

- "Error in source links : request failed with status 404

asset URL : https://cdn-paaprodweu.azureedge.net/v3.18064.24.80921456/studio/js/AppMagic.WebAuthoring.js?v=3.180...

Source Link URL : AppMagic.WebAuthoring.js.map"

 

I don't really know if these errors have nothing to do with my problem but well. But maybe it is my problem, because I have enabled CDN on my dev tenant.

 

Because on other client's tenant, I can put a datepicker and make it work fine.

 

SO if you have any idea, please let me know !! Smiley Wink