cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
prasadvenkat
Level: Powered On

Flow connection not working

I have a flow connection problem. Recently one of our developers quite and the flow was running with his connection. I tried changing the connection to a new one with my name, but keep getting the error "Some of the connections are not authorized yet. If you just created a workflow from a template, please add the authorized connections to your workflow before saving." . I am one of the owners to the sharepoint list, the PowerApps and the Flow that is running. Not sure what I am missing here. Any help is appreciated

6 REPLIES 6
Super User
Super User

Re: Flow connection not working

Did you create a new connection or change the account on the existing connection? Also, are you a co-owner of the Flow? Have you tried editing it.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Community Support Team
Community Support Team

Re: Flow connection not working

Hi @prasadvenkat 

 

Could you please reference @Pstork1 's suggestion?

And do you use the same account to singn in your flow and the connection?

Could you please reference this?

https://docs.microsoft.com/en-us/flow/add-manage-connections#troubleshoot-a-connection

 

Best Regards.

Yumia

prasadvenkat
Level: Powered On

Re: Flow connection not working

Hi,

I tried to create a new connection. Connection creates fine and upon saving the flow this error shows up. And yes, I am a co-owner to the flow, sharepoint. 



 

Super User
Super User

Re: Flow connection not working

If you created a new connection instead of changing the account on the existing connection, then I expect you will have to edit the Flow, check all the fields that come from the connection to make sure they are correct and then save the Flow again. Creating a new connection won't automatically replace the fields that were coming from the old connection. I suspect that's why you are getting the errors. Changing the account on the existing connection would have changed the permissions, but left all the rest of the connection in place.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
prasadvenkat
Level: Powered On

Re: Flow connection not working

Every thing is checked. The connection creates fine, but upon saving the error comes up. Looks like some inherent issue in flow

prasadvenkat
Level: Powered On

Re: Flow connection not working

ok, upon some more digging into the flow, there were other nodes that were requiring connections as well. Thanks for your replies. 

This post helped me in resolving the issue:

https://powerusers.microsoft.com/t5/General-Flow-Discussion/Some-of-the-connections-are-not-authoriz...

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Users Online
Currently online: 41 members 4,966 guests
Please welcome our newest community members: