cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NGuill
Level: Powered On

Issue with PowerApp showing image from Asset Library

I have two apps that I created that are identical except that the sharepoint lists are on two different private groups in Sharepoint.  Both apps work fine except that my original one shows images from the Asset Library on it's sharepoint group just fine.  The new one only shows the image if I run the app online though, not on mobile.  Does anyone have an idea on how to go about fixing this issue?

Community Support Team Rank
Community Support Team

Re: Issue with PowerApp showing image from Asset Library

Hi @NGuill,

Could you please share a bit more about your scenario?

Do you mean that the images from your SP Asset Library could not be displayed within PowerApps Mobile App of your Mobile device?

The user @sajarac has faced similar issue with you, please check the response within the following thread:

https://powerusers.microsoft.com/t5/General-Discussion/Share-point-pictures-can-not-be-seen-on-IOS-D...

It is a known issue that Pictures that need authentication on SharePoint are not supported in PowerApps Mobile App of Mobile device yet.

If you would like this feature to be added in PowerApps, please submit an idea to PowerApps Ideas Forum:

https://powerusers.microsoft.com/t5/PowerApps-Ideas/idb-p/PowerAppsIdeas

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
NGuill
Level: Powered On

Re: Issue with PowerApp showing image from Asset Library

The situation is that I have 2 SharePoint groups with duplicate lists, asset libraries, document, etc.  I therefore have 2 PowerApp apps, one for each SharePoint group.  One of my apps works perfectly and shows the images in both the mobile and online version.  The other app for the duplicated group doesn't show the images on the mobile version.  I've run through both sets of settings for the sites and I don't see any differences.

NGuill
Level: Powered On

Re: Issue with PowerApp showing image from Asset Library

I've done a little more digging and I believe when I created my first app, I was able to "copy link" for anyone, whereas that option is not available to me anymore.  Can you verify whether a group site of "https://trekfederation.sharepoint.com/sites/ussnathanhalecostaff" would be contained under the sharing permissions of "https://trekfederation.sharepoint.com/sites/share"?

Highlighted
o365masters
Level: Powered On

Re: Issue with PowerApp showing image from Asset Library

I have quite a few blogs on my website about different techniques you can use to render images stored in SharePoint document libraries within your apps.

The following blogs in particular consume photos saved specifically in a Site Assets library (inclusive of links to the demo apps showcased in each blog):

https://masteroffice365.com/sharepoint-graph-powered-photos-powerapps-mobile/

https://masteroffice365.com/leveraging-graph-in-powerapps-and-flow/