cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KMac1980
Level: Powered On

PowerApp trying to use Outlook Connector, but there is no connection in the app to outlook. Causing issue for users not migrated yet!

I have created a PowerApp that went live today. The only connections in the app are to SharePoint and one connection to start a Flow when the button is pressed. There are NO Outlook data connections in my PowerApp! However, I have a user that cannot open the PowerApp because he cannot sign in to the Outlook connector because he hasn't been migrated to Exchange Online yet! How on Earth can i get this connector to disappear!?! This is a huge app and I need everyone to be able to get to it!

outlookConnector.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
RezaDorrani
Level 10

Re: PowerApp trying to use Outlook Connector, but there is no connection in the app to outlook. Causing issue for users not migrated yet!

Hi @KMac1980 

 

2 things

 

1- check connections to make sure there are no orphaned Outlook connections in your App

 

2- PowerApps triggers/calls Flow in the context of the logged in user (this is by design)

Hence all connections in the Flow will also be applicable to the PowerApps

 

If your user does not have an exchange license, then you will have to rethink the approach of Flow being triggered from PowerApps since it will do so in the user context

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

3 REPLIES 3
Highlighted
RezaDorrani
Level 10

Re: PowerApp trying to use Outlook Connector, but there is no connection in the app to outlook. Causing issue for users not migrated yet!

Hi @KMac1980 

 

2 things

 

1- check connections to make sure there are no orphaned Outlook connections in your App

 

2- PowerApps triggers/calls Flow in the context of the logged in user (this is by design)

Hence all connections in the Flow will also be applicable to the PowerApps

 

If your user does not have an exchange license, then you will have to rethink the approach of Flow being triggered from PowerApps since it will do so in the user context

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

KMac1980
Level: Powered On

Re: PowerApp trying to use Outlook Connector, but there is no connection in the app to outlook. Causing issue for users not migrated yet!

My Flow's sole purpose is to email a printable view of the form so that the email can be attached to an InfoPath form that hasn't migrated and is so complex that no changes are allowed to be made unless it is 1,000% necessary lol.

 

Soooo, this would be why we are seeing it out of nowhere then. @RezaDorrani  there's no way to get around this is there?

 

KMac1980
Level: Powered On

Re: PowerApp trying to use Outlook Connector, but there is no connection in the app to outlook. Causing issue for users not migrated yet!

@RezaDorrani  Thank you so much for the quick response! I have a second app that uses the exact Flow and i removed it and it no longer prompts for an Outlook connection! I am slightly annoyed, but it is better than 172 people not being able to access the app! 

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Users Online
Currently online: 65 members 4,638 guests
Please welcome our newest community members: