cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kagoodm
Level: Powered On

PowerApps NewForm not saving new record to SharePoint

We have a SharePoint Online list (I'll call it improvements for now).  We added all of our columns to the list - some text, some choice.  We then said to customize the form with PowerApps.  Our PowerApp has 3 screens ScrnView with form frmViewItem, ScrnEdit with form frmEditItem, and ScrnCreate with form frmCreateItem.  We added another data source to the PowerApp for a 2nd SharePoint Online list which we house data in which feeds the drop down/choice fields (I'll call it improvement data lookup for now).

 

Once we got the screens set to have the fields we wanted displayed on each, we unlocked the data card on our choice type fields on our ScrnCreate/frmCreateItem and set "Items" property on the choice field to filter the improvement data lookup list by a value chosen in another field on our PowerApp.  We have a total of 5 drop down/choice fields on the PowerApp which we did this for.   In the SharePointIntegration section of the PowerApp, we have all of our properties set correctly referencing our own form names and screen names.

 

We saved our PowerApp and published it to SharePoint.

 

When we go to our SharePoint list (improvements) and click New, we get the ScrnCreate that opens and we can fill out all our fields and the drop downs are all working perfectly.  The problem is when we click Save, it does nothing!  There are 5 little dots that go scrolling across the top of the page, but then they disappear and we are left sitting on our new screen we just entered our data into.  No error messages displayed or anything!  We've confirmed we have all of our required fields filled in, so that's not the problem.

 

Any ideas what the problem may be??

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
kagoodm
Level: Powered On

Re: PowerApps NewForm not saving new record to SharePoint

We now have this working.  We recreated our columns in SharePoint as single line of text type fields then pulled them into the PowerApp form, deleted the textinput from the PowerApp form and added back as a drop down.

 

 

3 REPLIES 3
Community Support Team
Community Support Team

Re: PowerApps NewForm not saving new record to SharePoint

Is it the following article that you followed to configure the multiple screen for the forms?

SharePoint custom forms: Separate forms 

 

If convenient, could you please share more details about the steps to configure the choice field?

I will take a try to see if it could be reproduced from my side.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
kagoodm
Level: Powered On

Re: PowerApps NewForm not saving new record to SharePoint

Yes, that article is basically what we followed only we tweaked the names slightly to match some of our own naming standards.

 

Below are the steps we performed:

 

1) Build a SharePoint Online custom list called "Improvements".

 

2) In this custom list, we created a choice type field called "Plant" with 2 static values of A and B.

 

3) In this list, we also created a choice type field called "Location 1".  Since we wanted the selections to be pulled from a separate SharePoint Online custom list called "Improvement Data Lookup" but filter based on the Plant chosen and another column called Record Type with a value of "Location 1", we set the value section to 0 since it wouldn't let us create a choice field with no values specified.

 

4) We built a SharePoint Online custom list called "Improvement Data Lookup".

 

5) In this custom list, we have 3 columns all of type "single line of text".  The columns are named Record Type; Plant; and Value.

 

6) We loaded some data in this custom list so we had multiple records with Record Type = Location 1, Plant = A, and various values.  We did the same for Plant = B.  We also have entries for other record types like Identified From, Auditor, etc.

 

7) We then chose Customize Form from our "Improvements" list to build the PowerApp.

 

8) We followed the article you referenced about duplicating the screen twice, then renamed accordingly to a ScrnView, ScrnCreate, ScrnEdit and also renamed the default forms to match frmViewItem, frmCreateItem, frmEditItem.  We also set the SharePointIntegration properties for the OnSave, OnNew, OnEdit, OnView, and OnCancel.

 

9) We removed some of the fields from the Create and Edit screen such as the modified by, created by, etc.

 

10) We went to View -> Data Sources -> + Add data source and added in our connector to the "Improvement Data Lookup" SharePoint list.

 

11) On the ScrnCreate - frmCreateItem, we chose the data card for our Location 1 drop down and unlocked the card.

 

12) We then clicked on the actual drop down control within the card and set the "Items" property to the following:

(Filter('Improvement Data Lookup',Plant=DataCardValue4_2.Selected.Value,Record_x0020_Type="Location 1")).Value

 

DataCardValue4_2 in this example represents the Plant drop down on our PowerApp.

 

13) In PowerApps, we clicked File -> Save then chose to Publish to SharePoint.

 

When we open the "Improvements" SharePoint list and click the +New button, we see the correct ScrnCreate show up and the drop downs are working perfectly.  The values in the Location 1 field change based on the value chosen int he Plant drop down, however when we click the default Save button on the screen, nothing happens.  5 little dots scroll across the top of the page as if it is going to save, but it doesn't and the screen just sits there.  No error messages or anything.

 

 

kagoodm
Level: Powered On

Re: PowerApps NewForm not saving new record to SharePoint

We now have this working.  We recreated our columns in SharePoint as single line of text type fields then pulled them into the PowerApp form, deleted the textinput from the PowerApp form and added back as a drop down.