cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Powerapps flow run shows no parameter expected

Hello Team, I have a flow to connect to Azure Blob and then run OCR on the image which is stored in the image. Flow works as expected given that the static image value is set while running the flow. I want to pass dynamic values to flow using power apps. As per the process, I do have "Ask in Power Apps" set. My flow expects one argument in power apps. When I run the flow from Power apps button, my flow do not expect any argument and throws error on passing one. Please find the attached snapshots.
Community Support Team Rank
Community Support Team

Re: Powerapps flow run shows no parameter expected

HI @ashay-maheshwar,

Could you please share more details about the error message within your flow?

Do you mean that the Getblobcontent Dynamic content in your flow is not passed from your app?

Please check if you have passed proper Blob content path from your app to your flow.

In addition, please check if you have provided a proper value for the Getblobcontent argument of your 'YourFlowName'.Run() function in your app.

Please also consider re-create an new app, and add your flow connection within it, try your 'YourFlowName'.Run() function again, check if the issue is solved.

More details about starting a flow from an app, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/using-logic-flows

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.