cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
CABIRD
Level: Powered On

Swagger file connector Internal Server Error (500)

I've spent days attempting to resolve this. Todate I've been unsuccessful. Most articles are probably out of date.

 

Testing with Postman absolutely no issue. Functions perfectly. Building swagger file and using this to create a Power App connector and total failure. I've had this working in the past without issue. When it comes to testing see images below. Tried running PowerApp and fails.

 

Connector1.pngConnector2.pngConnector3.pngConnector4.png

 

Any ideas?

 

Thank you.

 

3 REPLIES 3
v-yutliu-msft
Level 10

Re: Swagger file connector Internal Server Error (500)

Hi @CABIRD ,

How do you create the custom connector?

Please check the following articles to make sure that there are no errors in creating custom connector.

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/register-custom-api

What's more, please check your authentification whether can get the request data.

Here's a similar problem that someone met, you could refer this:

https://powerusers.microsoft.com/t5/Common-Data-Service-for-Apps/Can-t-do-custom-connector-from-url/...

 

 

Best regards,

Community Support Team _ Phoebe Liu

CABIRD
Level: Powered On

Re: Swagger file connector Internal Server Error (500)

Hello @v-yutliu-msft 

 

I deleted the previous connector.

 

I used Postman and imported the collection.

 

No authentication. Testing the connector and report suggests all is well.  However issue appears ' Invalid number of arguments: recieved two expected five.

 

SubmitToFlow.png

CABIRD
Level: Powered On

Re: Swagger file connector Internal Server Error (500)

Hello @v-yutliu-msft 

 

I've added Power App, Flow & Swagger file. Hopefully help identify the issue. Thank you.