cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted

Using PowerApps Flow Condition_Object as Parameter

image.png

I've created a Flow in PowerApps that has 3 parameters. The ID always has worked for me and sends over correctly, but for some reason conditions do not work and always are "false" in the Flow. I am passing the value "true" as the parameter for both Condition_ObjectNames yet it returns false when I have the condition in Flow: 

image.png

 

Am I doing something wrong? Do the Condition_Objects work differently than other parameters? 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Using PowerApps Flow Condition_Object as Parameter

I discovered the problem. I should have put the text as just true without parenthesis. The problem is that this turns it into a boolean of true instead of the String. So I just changed it to yes and no instead of true or false and it works fine.

3 REPLIES 3
Community Support Team
Community Support Team

Re: Using PowerApps Flow Condition_Object as Parameter

Hi @Alerts_OM_USA

 

I can reproduce this. I have only "true" in the textinput control and it still shows False in Flow. I will try to discuss this with others and see if they have any suggestions.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Re: Using PowerApps Flow Condition_Object as Parameter

@v-monli-msftHave you been able to find any suggestions for this yet?

I did a test and found that the value shows up as "true" if I test it sending in  an email. But the Condition still returns false.

I also added a compose where I put the parameter, and then tried to use the compose output in the condition and it still doesn't work. The compose clearly shows a value of "true" and when compared in a condition it returns false.

Re: Using PowerApps Flow Condition_Object as Parameter

I discovered the problem. I should have put the text as just true without parenthesis. The problem is that this turns it into a boolean of true instead of the String. So I just changed it to yes and no instead of true or false and it works fine.