cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WayneS1
New Member

Sharing App with Sharepoint connector with Guests Errors

Hi All,

 

I have been working on a app that gathers data from a SharePoint list with the intention that it can be shared with guests however I don't seem to be able to share it without errors externally. I am following the guidance on the MS website so I'm not sure where I'm going wrong or if this is just possible yet. I have provided my procedure and errors below and if anyone could help I would appreciate it, Please ask if you require anymore information. 

 

I invite the external account to join our tenant as a guest is Azure AD.

I assign the guest account a power-apps license in Azure AD

I add the guest to the SharePoint site's membership which allows them to read the list that is showing in the app.

 

The guest then receives two email's, 1  to join our organisation as a guest which all is ok, The 2nd email is sharing the powerapp with them, When following the link they get something that looks like the below image 

3A969E17-A877-470B-B623-AFB092C0C4B7.jpeg

the only difference being there is no pre-populated email address, When the guest try's to sign in and allow I'm guessing to authorise or create a SharePoint connection it returns an authentication error and provides a session ID but that's all.  

I hope this makes sense , I appreciate any help anyone can provide. 

2 REPLIES 2
R3dKap
Super User
Super User

Hi @WayneS1,

You should post your question here: https://powerusers.microsoft.com/t5/Building-Power-Apps/bd-p/PowerAppsForum1 as it is THE place where most questions are answered... 😉

That said, I've made a test on my side:

  • added a guest user to my tenant
  • assigned it with a Power Apps Plan 2 Trial license
  • added the guest to a SharePoint site as a member
  • created a Power Apps simple app showing the content of a list from that site inside a DataTable control
  • shared the app with the guest

Then, in a private window I navigated to the app and authenticated with the guest account. I saw the permission popup show up and clicked Allow and my app started fine and showed me the content of the SharePoint list.

Everything seems to work fine this way on my side.

Maybe post a ticket to MS... 🤨

Hi Red,

 

Thanks for your reply and guidance on where to post my question , I'm a newbie on here so it's appreciated. 

see that's what I can't understand as soon as it comes to added to the permissions shown in my image as soon as I enter the guests email and password I get the same error message over and over again. But if I were to enter my organisational username and password it works fine. 

im wondering if any settings on my tenant would stop guests from accepting the connector permissions. 

Wayne

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Users online (2,933)