cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
schuess2
Level: Powered On

2 Column Form Layout

I have a Form with a 2 Column layout, however it is not working and I do not understand. The Data Source is Azure SQL. 

Here in the form settings screen cap you can see i have set it to 2 columns and the width of the form is 836px.

form settings.png

You can see from the data card settings that it is automatically dividing the form width by 2 and setting the width of the data card to 418px.

data card settings.png

Do you have any ideas for me?

1 ACCEPTED SOLUTION

Accepted Solutions
schuess2
Level: Powered On

Re: 2 Column Form Layout

It looks like if i turn off snap columns to grid, and size them myself, i can get my 2 column looking format

4 REPLIES 4
Super User
Super User

Re: 2 Column Form Layout

When you click on Edit Fields is there only 4 fields showing and they are the same 4 fields showing on the left side of the form? I tried to reproduce the issue with an Azure SQL Table and the same form settings but everything worked as expected. Have you tried adding another Edit Form on the screen and see if that works any better?

schuess2
Level: Powered On

Re: 2 Column Form Layout

I actually have lots of fields. I am using a technique from Laura Rogers that hides fields depending on what form tab you are on. Do you think that is the problem?

schuess2
Level: Powered On

Re: 2 Column Form Layout

It looks like if i turn off snap columns to grid, and size them myself, i can get my 2 column looking format

Community Support Team
Community Support Team

Re: 2 Column Form Layout

Hi @schuess2 ,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

Please consider take a try to turn off/disable the "Improved app rendering (final validation)" option within Advanced settings of App settings of your app, re-publish and re-load your app, check if the issue is solved.

 

Also please consider take a try to re-create a new app based on your Azure SQL data source, try it again, check if the issue still exists.

 

In addition, please also consider take a try to turn off the "Lock aspect ratio" option and "Scale to fit" option within Advanced settings of App setting of your app, then re-load your app, check if the issue is solved:5.JPG

 

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.