Level 8
Posts: 123
Registered: ‎05-15-2016

Access wep apps broken since 22/03/2017



I had an app working perfectly fine and suddenly stopped populating data from Access Web app since last night. 

The formula below is used in the 'Items' property and it looks like PowerApps or AWA cannot match date fields (Date_x0020_Required and dpOrderDate.SelectedDate). Data populate when I remove the date filter. 



Filter('[Access].[Production Schedule]', Line = ddLine.Selected.Value && Date_x0020_Required = dpOrderDate.SelectedDate)


This only started happening this morning (22/03/2017 in Mel, Australia). Any support is highly appreciated. 



Community Support Team
Posts: 3,320
Registered: ‎06-22-2016

Re: Access wep apps broken since 22/03/2017

Hi Afernando,


I am not sure if there is some updates between PowerApps and Access Web App.
Please make sure the connection is properly connected, and try again later.
If you are still getting this issue, please feel free reply. I will try to collect and report it from my side.


Best regards,
Mabel Mao

Level 8
Posts: 123
Registered: ‎05-15-2016

Re: Access wep apps broken since 22/03/2017

Hi Mabel @v-yamao-msft,


Thanks for the comment. I found out what was causing the problem. My 'Date Required' column was a date only field in AWA and I was matching it with the selected date in dpOrderDate control. And it used to work fine.


But now it works only when the selected date is converted to a Date Time Value. And that also matches with the previous day. 

IE: If i select 23rd of march on the calendar, items with the date 22nd populate in the gallery. 


I think it has something to do with how powerapps formats date times. I tried the workaround mentioned in this post


but it's not working for me!