Showing results for 
Search instead for 
Did you mean: 
Level: Powered On

Attachments with a form not saving

I have built a form to upload data into a list.


My user has a requirement to add attachments when a new record is entered via the form.


I have added the Attachments DataCard to my form, and when I click I get the standard explorer to find a file, which then is listed in the form but has "Unsaved" next to it.


If I submit the form the attachments column has a paper clip in it, but I cannot see or access any attachments.


Help! Smiley Sad



Level 10

Re: Attachments with a form not saving

Do you have a screen shot?  Is the attachment actually attached to the  list (sharePoint?) but not showing on your form?

Community Support Team
Community Support Team

Re: Attachments with a form not saving

Hi @Scootteruk ,

Could you please share a bit more about your issue?

Do you mean that the Attachments control within your Edit form could not save attachments into your SP list?


Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.


When you attach files using the Attachments control within your Edit form, the new attached file would be recognized as "Unsaved":8.JPGOnce you submitted your record, and then edit the previous submitted record (attached with attachments) within your app, the uploaded files would be existed within the Attachments control:9.JPG

Please consider re-generate a new app based on your SP List, then enable the "Attachments" data card within your Edit form, submit a new record along with some attachments, then check if the issue is solved.


More details about generating an app based on SP list data source, please check the following article:


Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Level: Powered On

Re: Attachments with a form not saving

Upon submission of the form, the files are not saved and are no longer shown on the form when you edit from the SP list.


In fact, when I edit from the SP List, none of the data entered is present on the form it is a blank form


Any ideas?

Super User
Super User

Re: Attachments with a form not saving



Please refer to this post. Another user had this problem and the sugeestions have helped them.




If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Level 10

Re: Attachments with a form not saving

Do you have allow attachments turned on in the List Setting - Advanced

Helpful resources


Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020


Power Platform World Tour

Coming to a city near you


PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!


Join PowerApps User Group!!

Connect, share, and learn with your peers year-round


Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 56 members 4,910 guests
Recent signins:
Please welcome our newest community members: