cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AFWright
Level: Powered On

Azure SQL Data loads to PowerApps in browser but not on mobile devices

I have an app that relies on a Table and a View (both ~ 5000 items) to run. 

 

I'm using the following code. I tried it both "on app run" and using main screen "on visible". Everything loads fine on the desktop, but neither collection gets populated on a mobile device. I tried this with multiple users and the result is the same.

 

ClearCollect(RepCustomers, Filter( '[dbo].[vAOC_Customers]', Email = User().Email));
ClearCollect(ItemList, SortByColumns(Filter('[dbo].[vAOC_Items]', ActiveStatus = "Active" , CustomField_ItemStatus = "CORE" || CustomField_ItemStatus = "PILLAR" ), "Item_Name" ) )

1 ACCEPTED SOLUTION

Accepted Solutions
AFWright
Level: Powered On

Re: Azure SQL Data loads to PowerApps in browser but not on mobile devices

Found a solution with a help of a friend.

 

Turns out using a function to look up user email withing the delegated Filter function did not work. Creating a variable named "useremail" and using that to delegate the filter to the database solved the problem. 

3 REPLIES 3
Super User
Super User

Re: Azure SQL Data loads to PowerApps in browser but not on mobile devices

Just a quick check before looking at more complex possibilities - are you logged into the mobile devices with the same account as the browser?

Maybe put a label with User().Email on the screen just to be certain.

AFWright
Level: Powered On

Re: Azure SQL Data loads to PowerApps in browser but not on mobile devices

I did that before posting just to make sure and yes, they are the same. Only one of the collections is dependent on the user email, but neither loads in the app. 

 

 

AFWright
Level: Powered On

Re: Azure SQL Data loads to PowerApps in browser but not on mobile devices

Found a solution with a help of a friend.

 

Turns out using a function to look up user email withing the delegated Filter function did not work. Creating a variable named "useremail" and using that to delegate the filter to the database solved the problem. 

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

SecondImage

PowerApps Monthly Community Call

Next Wednesday, September 18th at 8am PDT

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 244 members 2,358 guests
Please welcome our newest community members: