cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PowerAnalytics
Level: Powered On

BUG: View Form

Hello everybody, currently there seems to be a huge bug regarding the display form control. First by selecting an item in my BrowseGallery everything seems ok and the display form control shows the correct data. By selecting another item in the same BrowseGallery the display form control always shows the data from the first selected item. I tried to Refresh my Datasource (onVisible property in the display form) but it doesn't work. Datasource: SharePoint List My PowerApp worked successfully until today. Can anyone help me and in addition confirm this bug? Thanks in advance. Stef
1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: BUG: View Form

Hi @PowerAnalytics,

Do you mean that the issue only appears in your Mobile device?

I have made a test on my side, and don't have the issue that you mentioned. I think this issue is not related to the Choice field in your SP list.

Please make sure the Item property of the Display form control is set to following:

BrowseGallery.Selected

Please also take a try to turn off/disable the "Improved app rendering (final validation)" option and "Delayed load" option within Advanced settings of App settings of your app, then re-publish your app, then try your PowerApps Mobile App again, check if the issue is solved.

In addition, please also check if the version of your PowerApps Mobile App in your Mobile device is the latest version, if not, please upgrade it into the latest version, then check if the issue still exists.

If the issue still exists, please consider re-create your app or re-install PowerApps Mobile App in your Mobile device, then check if the issue is solved.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
5 REPLIES 5
PowerAnalytics
Level: Powered On

Re: BUG: View Form

Update: This bug is related to choice fields in SharePoint Online because only choice columns are affected. Furthermore all textfields are working well - this means the fields show the right data on the display form. And this bug only appears on my mobile device. On my browser everything seems ok. I have also unsuccessful set the Default Property to Parent.Default as well as BrowseGallery.selected.item.
Community Support Team
Community Support Team

Re: BUG: View Form

Hi @PowerAnalytics,

Do you mean that the issue only appears in your Mobile device?

I have made a test on my side, and don't have the issue that you mentioned. I think this issue is not related to the Choice field in your SP list.

Please make sure the Item property of the Display form control is set to following:

BrowseGallery.Selected

Please also take a try to turn off/disable the "Improved app rendering (final validation)" option and "Delayed load" option within Advanced settings of App settings of your app, then re-publish your app, then try your PowerApps Mobile App again, check if the issue is solved.

In addition, please also check if the version of your PowerApps Mobile App in your Mobile device is the latest version, if not, please upgrade it into the latest version, then check if the issue still exists.

If the issue still exists, please consider re-create your app or re-install PowerApps Mobile App in your Mobile device, then check if the issue is solved.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
PowerAnalytics
Level: Powered On

Re: BUG: View Form

Hi @v-xida-msft,

I've turned off the options you've mentioned and now it works! Thank you so much for your support.

 

Best regards!

 

Stef

sdmikejr
Level: Powered On

Re: BUG: View Form

For those who experienced a similar problem while rending a canvas app in Sharepoint, the suggestion also fixed the problem there as well. Thank you!!

robinsc1
Level: Powered On

Re: BUG: View Form

Can confirm this issue is still present as of today.  This issue breaks the vanilla three-screen app created when taking data from a SharePoint list.  Turning off both settings as outlined here is what fixed the FormDisplay for me.  If you turn off only one, or none of those two settings, the FormDisplay does not display the correct information for any mulitple choice fields from a SharePoint list as described in the original post.  

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

SecondImage

PowerApps Monthly Community Call

Next Wednesday, August 21st at 8am PDT

Top Community Contributors for July 2019

Top Community Contributors for July 2019

Let's thank our top community contributors

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

FifthImage

Dynamics 365 and Power Platform April 2019 Release notes

Features releasing from April 2019 through September 2019!

SixthImage

Power Summit Australia 2019

August 20-23rd 2019

Users Online
Currently online: 49 members 4,416 guests
Please welcome our newest community members: