cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
darren2170
Level: Powered On

Can't return Attachment Control Name field... it work last week, now it just returns nothing.

 
Community Support Team Rank
Community Support Team

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Hi @darren2170,

 

Did you mean that the file name does not show in attachment control inside the Form? If so, I just tested and it seems that I cannot reproduce this issue. If you still got the issue, please try to delete the data card by unselecting the checkbox and check it back to have a test.

Capture.JPG

 

Regards,

Mona

soc_snow_it
Level: Powered On

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Hi!

I have the same problem now:

in Attachment Control I upload an Attachment and have that:

First(Attachments_Control.Attachments).Value i like this :  appres://blobmanager/......./

but
First(Attachments_Control.Attachments).Name  is Blank

 

while until last week

in Attachment Control when i was loading an Attachment the result was:

First(Attachments_Control.Attachments).Value i like this :  appres://blobmanager/......./

and
First(Attachments_Control.Attachments).Name : New Text Document.txt

 

PowerApps Staff Rank jovan
PowerApps Staff

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

I can confirm that this is a regression.  I am working on fixing it now.

 

The only workaround I can offer is rolling back the changes to the previous version.  If you then want to edit the app, you can edit it with previous version of studio.  You can reach it by modifying the studio URL like so:

https://us.create.powerapps.com/studio/#    ---->

https://us.create.powerapps.com/v3.18111.15.95585990/studio/#

 

 

soc_snow_it
Level: Powered On

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

I tried to follow the suggestion, but I have the following error ( see Error.JPG) when I try to open the app
can you give me the link of version 3.18111.17 that works?
thank you

PowerApps Staff Rank jovan
PowerApps Staff

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

You will first have to roll back your app to an earlier version:

 

  1. go to https://web.powerapps.com/
  2. click Apps
  3. find your app in the list, and click "..." then "Details"
  4. click on the "Versions" tab
  5. in the list of versions find one that is old enough to be using "PowerApps version" 3.18111.17 or earlier
  6. click on the "..." for that version and "Restore" to it

You can now edit your app with 3.18111.17.

Note that this version will not be Live (seen by your users) until you "Publish" it.  You can see that in the "Published" column of that same app version list.

soc_snow_it
Level: Powered On

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Thanks,
I rolled back to the last save in version  3.18111.17 and opened the app via the link
https://us.create.powerapps.com/v3.18111.15.95585990/studio/#
It works.

I am waiting for the problem to be solved for the future

Many thanks

sdbr
Level: Powered On

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Hello,

 

I am designing a custom form for a SharePoint list. Is there a way to edit the form with a older version of PowerApps? In the Sharepoint list I use the menu PowerApps-> Edit form. This redirects me to PowerApps page but brings me to the link https://eu.create.powerapps.com/studio/. When i add the version in the URL it brings me to the starting page of PowerApps and the form disappears. 

 

I would like to edit the form in a PowerApps version that does not have the empty name attribute problem in the attachment collection.

 

Thanks in advance!

 

Kind regards,

Stef

PowerApps Staff Rank jovan
PowerApps Staff

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

From SharePoint: Site Contents -> Site settings -> Site libraries and lists -> Customize “{your-list-here}” -> Form settings:

Also, Site Contents -> Site settings -> Site libraries and lists -> Customize “{your-list-here}” -> Form settings -> "See versions and usage" to manage the app, rollback versions, etc.

sdbr
Level: Powered On

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Hi @jovan,

 

Thanks for the reply.

 

I tried the suggestion but I get this message:

 

This app cannot be edited with this version of PowerApps.  Please go to web.powerapps.com and use PowerApps studio for web to edit this app.

 

Thank you!