cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User
Super User

Collect not receiving all data / columns from on prem SQL

Something very wierd is going on here... and its costing me hours!!

 

Using the web editor, a collect function recieves all data and my app works perfectly.

Using ios app or web player, its not collecting the data from all columns.

 

Ive added another button with the same formula in again, now the original button works..

Delete the additional button, it breaks again..

It gets the column header but no data at all.

 

SQL on premises data source.

 

Its not just doing it for one table/column/collection either and seems completely random.

Seems a HUGE bug somewhere.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Microsoft Employee

Re: Collect not receiving all data / columns from on prem SQL

Hello @Delid4ve,

Can you please try to disable "Explicit column selection" and re-publish the app?

2 REPLIES 2
Highlighted
Microsoft Employee

Re: Collect not receiving all data / columns from on prem SQL

Hello @Delid4ve,

Can you please try to disable "Explicit column selection" and re-publish the app?

Super User
Super User

Re: Collect not receiving all data / columns from on prem SQL

Thanks,

but absolutely ludicrous.

Its exactly that.

However, these are preview features... they shouldnt be turned on by default, dont expect BETA/Preview features to interfere with business software.

If we want to test then we turn them on ourselves in a test environment.

 

Just cost me nearly 4 hours.