cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Makjimmy
Level: Power Up

Custom Connector- 404 Resource Not Found

Dear Sir/Madam,

 

We have setup the Custom Connector, and we are successfully retrieve the record by calling the GET request to the data services.  However, when we tried to upload the records to the data services and the 404 operation failed was returned.  We had tried to submit the request by using command line curl and it works fine as below:

 

c:\curl\bin>curl -i -H "Content-Type: application/json" -X POST -d @Test2.json "
https://lzpllncuyb1rawz-adwc1.adb.us-ashburn-1.oraclecloudapps.com/ords/admin/emp/"
HTTP/1.1 201 Created
Date: Wed, 03 Jul 2019 15:26:28 GMT
Content-Type: application/json
Transfer-Encoding: chunked
Connection: keep-alive
Location: https://lzpllncuyb1rawz-adwc1.adb.us-ashburn-1.oraclecloudapps.com/ord
s/admin/emp/9050
X-ORACLE-DMS-ECID: f0b35670-e4e8-4d29-826e-c58271e2834d-00000f30
ETag: "wzjIjuiyU0P8bqE/A4puBb859S3OuI6xDf1K0G7urbix1eD28Awm06xvvqlTBjbQX0zezfmGphfIJzjmT8/Qsw=="
Content-Location: https://lzpllncuyb1rawz-adwc1.adb.us-ashburn-1.oraclecloudapps.com/ords/admin/emp/9050
X-ORACLE-DMS-RID: 0

{"empno":9050,"ename":"HENRY","job":"CLERK","mgr":7902,"hiredate":null,"sal":8000,"comm":null,"deptno":20,"links":[{"rel":"self","href":"https://lzpllncuyb1rawz-adwc1.adb.us-ashburn-1.oraclecloudapps.com/ords/admin/emp/9050"},{"rel":"edi..."}]}

 

The configuration of the Custom Connector is as attached and please help to fix the issue.  Thanks.

 

Best Regards,

 

Jimmy

2 REPLIES 2
Community Support Team
Community Support Team

Re: Custom Connector- 404 Resource Not Found

Hi @Makjimmy ,

Is the "https://lzpllncuyb1rawz-adwc1.adb.us-ashburn-1.oraclecloudapps.com" your host name of your API Service?

Which authentication type do you use within your custom connector? No Authentication?

Further, is your data service installed on your local machine?

 

If your data service is deployed within cloud, you do not need to enable the "Connect via on-premises data gateway" option as below:1.JPG

 

If your data service is installed within your local machine, please consider provide a proper Authentication type within your custom connector to connect to your data service.

 

Also please check if you have typed a proper Request URL and Request Body within your custom connector to execute the POST action.

 

More details about creating a custom connector in PowerApps, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/register-custom-api

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Administrator
Administrator

Re: Custom Connector- 404 Resource Not Found

Hi @Makjimmy how are you progressing with this? Was the above reply helpful?

 

@TopShelf-MSFT 

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

SecondImage

Follow PowerApps on Twitter

Stay Up-to-Date by following PowerApps on Twitter

Top Community Contributors for July 2019

Top Community Contributors for July 2019

Let's thank our top community contributors

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

FifthImage

Dynamics 365 and Power Platform April 2019 Release notes

Features releasing from April 2019 through September 2019!

Users Online
Currently online: 41 members 4,109 guests
Please welcome our newest community members: