cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
RussWils1
Level: Power Up

Custom Connector - issue converting to WADL

I'm attempting to create a Custom Connector in PowerApps via "Use an OpenAPI URL", but when I choose "Create Connector" the following warning is displayed:

 

Your custom connector has been successfully created, but there was an issue converting it to WADL for PowerApps: Encountered internal server error. The tracking Id is '*********************************************'.

 

I cannot then create a DataSource using this connector as i receive this error:

 

No wadlUrl is specified for this Api. This usually indicates there was an error when converting the Swagger associated with this api to a WADL file.
apiId: *******************************************************************************************************

 

Is there something wrong with my Swagger defintion?

 

Here is my swagger definition:

 

{
"swagger": "2.0",
"info": {
"version": "v1",
"title": "test REST API",
"description": "test REST API",
"termsOfService": "None"
},
"host": "test.azurewebsites.net",
"basePath": "/",
"paths": {
"/api/Entities/CommercialClients/{clientId}": {
"get": {
"tags": [
"CommercialClients"
],
"summary": "Obtains the details of the specified Commercial Client internal code",
"operationId": "ApiEntitiesCommercialClientsByClientIdGet",
"consumes": [],
"produces": [],
"parameters": [
{
"name": "clientId",
"in": "path",
"description": "The Commercial Client internal code",
"required": true,
"type": "integer",
"format": "int32"
},
{
"name": "select",
"in": "query",
"description": "Sections of details to return.",
"required": false,
"type": "string"
}
],
"responses": {
"200": {
"description": "Success"
}
}
}
}
},
"securityDefinitions": {}
}

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Custom Connector - issue converting to WADL

Hi RussWils1,

 

There is nothing wrong with the Swagger file you provided. It converts just fine using the existing Swagger to WADL converter. Please try to re-upload the Swagger file via the PowerApps Dashboard.

 

Please try it again and feel free reply if you are still having the same issue.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
1 REPLY 1
Community Support Team
Community Support Team

Re: Custom Connector - issue converting to WADL

Hi RussWils1,

 

There is nothing wrong with the Swagger file you provided. It converts just fine using the existing Swagger to WADL converter. Please try to re-upload the Swagger file via the PowerApps Dashboard.

 

Please try it again and feel free reply if you are still having the same issue.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

SecondImage

PowerApps Monthly Community Call

Next Wednesday, September 18th at 8am PDT

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 49 members 4,333 guests
Please welcome our newest community members: