cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User
Super User

Datasourceinfo doesnt work

Trying to hide a gallery based on delete permissions.

 

Ive shared the app with a user and restricted permissions in sharepoint so the only way the user can edit the list is through the app.

When using (Datasourceinfo(tablename,DeletePermission) it always evaluates to true.  Yet the user does not have the delete permission available.

I have also removed edit permission (as i know windows deletes and recreates on edit) and thought sharepoint may be the same, however this still does not work so im guessing there is a bug.

 

In sharepoint 

List Permissions

Add items

Edit Items

View Items

Open Items

View Versions

Site Permissions

Browse Directories

View Pages

Enumerate Permissions

Browse User information

Use Remote Interfaces

Use Client Integration Features

Open

Personal Permissions

none

9 REPLIES 9
Highlighted
Community Support Team
Community Support Team

Re: Datasourceinfo doesnt work

Hi Delid4ve,

 

So you are working with SharePoint list. What’s the permission level you specified for shared users for the list?


And what’s the permission you set for the shared users when sharing the app?


It seems that I am getting the same results with you.


I will help confirm with this issue on my side and back to you once I got any updates.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Meneghino
Level 10

Re: Datasourceinfo doesnt work

I can confirm the same problem.

 

My user does not have delete permission on a document library, but

DataSourceInfo(Documents, DataSourceInfo.DeletePermission)

evaluates to true.

 

@v-yamao-msftplease escalate without delay.

Johnathon_S
Level: Powered On

Re: Datasourceinfo doesnt work

I have the same issue in SharePoint list. DataSourceInfo always returns true no matter what the permission. 

Community Support Team
Community Support Team

Re: Datasourceinfo doesnt work

Hi All,

 

I have some updates for you.

 

The SharePoint connection (being an OAuth connection) is created per-user and executes with the permissions of the end user. So if the SharePoint list permissions were restricted for the end users then it makes sense that the end user wouldn’t have the delete permission. The user permissions are what matters; the app doesn’t have any special permissions and OAuth connections aren’t shared (whereas SQL connections and non-OAuth custom connector connections are shared).

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Johnathon_S
Level: Powered On

Re: Datasourceinfo doesnt work

Then you aren't able to show/hide/disable buttons or content based on permissions if you use SharePoint? That's a lot of user experience just gone. 

Grahambo05
Level 8

Re: Datasourceinfo doesnt work

@v-yamao-msft any update on this?

 

 

skylitedave
Level 10

Re: Datasourceinfo doesnt work

I see the same issue with DataSourceInfo connected to SharePoint lists and dont follow the response given about the OAuth connection.  If the connected user using a unique connection to a SharePoint list does not have permissions specified in SharePoint for that connection to that list, then the DataSourceInfo should return the proper response.  

 

We could really use this capability for wads and wads of functionality in the apps connected to SharePoint lists and right now, it does not work at all.... I can confirm the function always returns true no matter what permissions the connected user has been granted to that list using that connection.  It is a bug and not the desired/required functionality we need.

larivibi
Level: Powered On

Re: Datasourceinfo doesnt work

Please @v-yamao-msft , can you confirm that you are still investigating the matter

Martine
Level: Powered On

Re: Datasourceinfo doesnt work

I have the same issue.  Any solution?

 

Thanks,

Martine.

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 269 members 5,447 guests
Please welcome our newest community members: