cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
long
Level: Powered On

Detail screen problem not displaying correct information

I am having an issue with a powerapp that I'm creating from a sharepoint online list.  I created the app from the sharepoint list and have the three basic screens, Gallery, detail and edit.  When I publish the app and run it and select an item on the gallery it displays the info in the details screen correctly.  When I go back to the gallery and select another item it displays the name information from the first selection however the other information such as dates and times are correct for the item seleted.  I have trouble shooted this for several days and don't understand why this is happening.  Any help would be appreciated.   

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
long
Level: Powered On

Re: Detail screen problem not displaying correct information

I found this solution in another post that fixes the issue.  I turned the two options off and it worked.  Hope it helps.

 

 

 
Profile picture of v-xida-msft
Community Support Team Rank
Community Support Team
Re: BUG: View Form
 

Hi @PowerAnalytics,

Do you mean that the issue only appears in your Mobile device?

I have made a test on my side, and don't have the issue that you mentioned. I think this issue is not related to the Choice field in your SP list.

Please make sure the Item property of the Display form control is set to following:

BrowseGallery.Selected

Please also take a try to turn off/disable the "Improved app rendering (final validation)" option and "Delayed load" option within Advanced settings of App settings of your app, then re-publish your app, then try your PowerApps Mobile App again, check if the issue is solved.

In addition, please also check if the version of your PowerApps Mobile App in your Mobile device is the latest version, if not, please upgrade it into the latest version, then check if the issue still exists.

If the issue still exists, please consider re-create your app or re-install PowerApps Mobile App in your Mobile device, then check if the issue is solved.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
3 REPLIES 3
KickingApps
Level 8

Re: Detail screen problem not displaying correct information

@long I have been experiencing issues with an app tied to SharePoint also -- since yesterday.  Not sure if it is related to some other issues that were reported related to PowerApps and Azure (?) but it might be what is causing the problems.  It might be helpful, if you can, to do a screen capture and report it as a bug.

long
Level: Powered On

Re: Detail screen problem not displaying correct information

Interesting im working with powerapps and a sharepoint list.  If your working with Azure it leads me to beleive this is a powerapps issue.  Will report as a bug.

 

Thanks for the info.

Highlighted
long
Level: Powered On

Re: Detail screen problem not displaying correct information

I found this solution in another post that fixes the issue.  I turned the two options off and it worked.  Hope it helps.

 

 

 
Profile picture of v-xida-msft
Community Support Team Rank
Community Support Team
Re: BUG: View Form
 

Hi @PowerAnalytics,

Do you mean that the issue only appears in your Mobile device?

I have made a test on my side, and don't have the issue that you mentioned. I think this issue is not related to the Choice field in your SP list.

Please make sure the Item property of the Display form control is set to following:

BrowseGallery.Selected

Please also take a try to turn off/disable the "Improved app rendering (final validation)" option and "Delayed load" option within Advanced settings of App settings of your app, then re-publish your app, then try your PowerApps Mobile App again, check if the issue is solved.

In addition, please also check if the version of your PowerApps Mobile App in your Mobile device is the latest version, if not, please upgrade it into the latest version, then check if the issue still exists.

If the issue still exists, please consider re-create your app or re-install PowerApps Mobile App in your Mobile device, then check if the issue is solved.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 177 members 4,715 guests
Please welcome our newest community members: