cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
westerdaled
Level: Powered On

Gallery giving odd Title1 error

Hi

 

 

I am testing out a couple of PowerApps to be embedded in a demo SharePoint page.

 

  1. Added a vertical gallery to a page 
  2. Connected it to a SharePoint list.  The Title field ( static name) has been renamed on the list to display value shown
  3. removed image and subtitle fields from the Gallery
  4. Added an HTmL imput field on to the Gallery and wired it to one of the SharePoint fields
  5. I get this odd error with the gallery ( see attachment)  - anyone see this annoying error Smiley Embarassed  Note this my second attempt to build this PowerApp
1 ACCEPTED SOLUTION

Accepted Solutions
westerdaled
Level: Powered On

Re: Gallery giving odd Title1 error

@gmaasz 

 

Thanks for your reply.  This wasn't the answer but you kind of made me think about the issue.  The error seemed to reference a field that didn't exist .  Actually a whole load of property values that didn't exist.  So it seems all I needed to do was to change title to title1 wherever it is referenced.

 

property values incorrect.PNG

Not at all obvious and causing newbies like me a headache!

 

 

 

2 REPLIES 2
gmaasz
Level: Powered On

Re: Gallery giving odd Title1 error

Maybe try specifying the data type after the field added in the gallery:

 

ThisItem.'Suggestion Name'.Text

westerdaled
Level: Powered On

Re: Gallery giving odd Title1 error

@gmaasz 

 

Thanks for your reply.  This wasn't the answer but you kind of made me think about the issue.  The error seemed to reference a field that didn't exist .  Actually a whole load of property values that didn't exist.  So it seems all I needed to do was to change title to title1 wherever it is referenced.

 

property values incorrect.PNG

Not at all obvious and causing newbies like me a headache!