cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
kchumon
Level: Powered On

HTML text block not displaying

Hi all!

 

I'm working on a powerapp to manage a list of requests and trying to do 2 diferent htmlText blocks. 1 for a pdf generation and the other for a html email receipt. when I first created the PDF one. It was displaying fine and generating the PDF's. Suddenly it was not rendering on screen but still will produce the PDF and I thought it was the modification for adding images for the PDF file what broke the display. Now it wont render and throws an error on the PDF creation process. The second one for the email doesn't render and also haven't been able to include on an email.

 

WIll appreciate any insights about this that is driving me nuts. I believe that is something on the powerApps limited HTML and me using things not allowed but can't figure out what it is.

1 ACCEPTED SOLUTION

Accepted Solutions
kchumon
Level: Powered On

Re: HTML text block not displaying

As an update...

 

Got the display issue resolved. (some of the references to data where missing the attribute to display)

Also got the PDF to run again. This I will possibly need some help. I had the onSelect of an icon to:

CreatePDF_1.Run(PDFtext.HtmlText, "Record # " & BrowseGallery1.Selected.ID & " for " & BrowseGallery1.Selected.Requestor);
Patch('Sodexo Requests', LookUp('Sodexo Requests', ID = BrowseGallery1.Selected.ID), {Submitted: Now()})

I want it to create the PDF and timestamp the submitted field on the SP list. Both functions work if done in separate instances but I want it to happen with the same button.

Any ideas on what is wrong there?

2 REPLIES 2
kchumon
Level: Powered On

Re: HTML text block not displaying

And forgot to include the error I'm getting on the run PDF flow and it is basically related to the variable that points to the HTML text block

runPDFerror.jpg

kchumon
Level: Powered On

Re: HTML text block not displaying

As an update...

 

Got the display issue resolved. (some of the references to data where missing the attribute to display)

Also got the PDF to run again. This I will possibly need some help. I had the onSelect of an icon to:

CreatePDF_1.Run(PDFtext.HtmlText, "Record # " & BrowseGallery1.Selected.ID & " for " & BrowseGallery1.Selected.Requestor);
Patch('Sodexo Requests', LookUp('Sodexo Requests', ID = BrowseGallery1.Selected.ID), {Submitted: Now()})

I want it to create the PDF and timestamp the submitted field on the SP list. Both functions work if done in separate instances but I want it to happen with the same button.

Any ideas on what is wrong there?

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 65 members 4,564 guests
Please welcome our newest community members: