cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jdvroum
Level: Powered On

Re: Image does not display in Mobile apps & IE

Erga,

Thanks for your answer and sorry for my english :-)

My problem is a bit more complicate. I have a list of players (PLAYERS) and an asset library (BASEIMAGES). I want to associate the country include in the list of the player with the picture of this country include in the asset library. 

 

First, I'm not sure that I agree to used Asset Library and no Pictures gallery ? I don't succed to do what you explain with this asset library !

 

Julien

NickiGreene2
Level: Powered On

Re: Image does not display in Mobile apps & IE

Hi, Is there any update to this? I am experiencing the same issue with Images not displaying when using the PowerApp solution on a mobile device.

PowerApps Staff erga
PowerApps Staff

Re: Image does not display in Mobile apps & IE

@NickiGreene2 Can you copy and paste the image URL you are trying to use? If the image is privately hosted (i.e. requires a logged-in user to view, like most Sharepoint images), we cannot display the image unless it is a column in a table of an authenticated data source. 

 

An authentication-required image may show up on your web browser but not on your mobile devices because your web browser saves browser cookies containing your authentication credentials, while your mobile device cannot save these cookies. Thus, on your mobile devices the images will not display. 

PowerApps Staff erga
PowerApps Staff

Re: Image does not display in Mobile apps & IE

@jdvroum You can create a SharePoint connection to achieve what you want here. Create a new list on Sharepoint with two columns -- one named "Player" and another named "Player Image" (you can choose other names). Then upload your images onto the SharePoint list as an attachment on your Sharepoint site. Finally, on your PowerApp, add your SharePoint connection to your PowerApp and bind it to a Gallery control.

 

For more information, you can visit https://docs.microsoft.com/en-us/powerapps/connections/connection-sharepoint-online. 

jdvroum
Level: Powered On

Re: Image does not display in Mobile apps & IE

@ergaMerci for your answer. I will try as soon as possible.

Your link was dead but I imagine that it's this page : https://docs.microsoft.com/en-us/powerapps/connections/connection-sharepoint-online

Anandavadivelan
Level: Powered On

Re: Image does not display in Mobile apps & IE

Thank you, this worked for me. 

jdvroum
Level: Powered On

Re: Image does not display in Mobile apps & IE

 
jdvroum
Level: Powered On

Re: Image does not display in Mobile apps & IE

Hello, I dont really understand. I create one list with lookup from my list "players" and lookup from my gallery "players images". I don't understand why I need to upload images in attachement ? Do I need to upload two times my pictures ? Can you help me ? Julien
Highlighted
TKrause5
Level: Powered On

Re: Image does not display in Mobile apps & IE

I was having the same issue... I had a gallery that displayed images in a SharePoint list. The images were on a remote server outside of the SharePoint site. I had a SharePoint list with a picture column. I used the URL for the images on the remote server in my SharePoint picture column. The images were showing in web browser BUT were not showing on mobile device. 

 

I resolved it by uploading the images to a google sites and replacing the URL in the SharePoint list with the google sites URL and the pictures displayed on mobile device. 

 

Not sure why the remote server I originally hosted the images on did not work for mobile device BUT google sites did work. 

 

Try creating a google sites page and uploading the images there. Then use the URL from googles sites in SharePoint and see if that works for you. 

 

johnguilbert197
Level: Powered On

Re: Image does not display in Mobile apps & IE

Still having issues with Images not loading in PowerApps Mobile. One day they are fine, next they do not appear. I have noticed that the Tenant Blob Caches are having issues right across the board. Pictures on SharePoint Online Logos disappear (even after CTRL F5). I have issues pictures disappearing full stop.  

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

SecondImage

PowerApps Monthly Community Call

Next Wednesday, August 21st at 8am PDT

Top Community Contributors for July 2019

Top Community Contributors for July 2019

Let's thank our top community contributors

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

FifthImage

Dynamics 365 and Power Platform April 2019 Release notes

Features releasing from April 2019 through September 2019!

SixthImage

Power Summit Australia 2019

August 20-23rd 2019

Users Online
Currently online: 52 members 4,386 guests
Please welcome our newest community members: