cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vnguyen
Level: Powered On

OnStart does not work consistently

Hi all, 

 

I have played around with Powerapps recently to create an app for my company. I want my app to automatically create a UniqClient collection whenever the app is lauched. The UniqClient will contain a list of client names who have done business before. However, I do not want to have the repeated name of client as that client may have multiple projects with us. 

 

I have tried to put this following formula ClearCollect(UniqClient,Distinct(TableTesting_1,Clients)) into OnStart. It works but not consistently on the Edit mode. However, it doesn't work at all whenever I actually play my app.  I know the collection is created but with an empty list even though I have close/re-open the app. 

 

Do you know if there is solution for this issue? Any suggestion or workaround? I know OnVisible works, but I still want to create a collection as the app starts and ready to go, rather than switch between the screens to make my app work. 

 

Thanks, 

 

 

4 REPLIES 4
Super User
Super User

Re: OnStart does not work consistently

https://powerapps.microsoft.com/en-us/blog/performance-considerations-with-powerapps/

 

At the bottom of that article he walks through how to use a Timer Control to do what I believe you want to do. 

Shane - Microsoft MVP, YouTube, and PowerApps Consulting for when you are in a bind to get this fixed quickly. And finally we now have PowerApps Training
vnguyen
Level: Powered On

Re: OnStart does not work consistently

Hi Shane, 

 

Thank you for sharing an interesting tutorial. I just incorporated the timer control and "splash screen" to my app. Now my collection is created under the preview mode, but not under Edit or Play app modes. In addition, I have set the duration of timer down to 0.001 but it's not fast enough in order for the user dont see the transition from splash screen to my browsescreen.  Am I missing something ? 

Super User
Super User

Re: OnStart does not work consistently

I think you would want to make it so your splash screen sits there, maybe show them an animated loading, while the collection is built. Then when it is done jump to the actual work screen. 

Shane - Microsoft MVP, YouTube, and PowerApps Consulting for when you are in a bind to get this fixed quickly. And finally we now have PowerApps Training
vnguyen
Level: Powered On

Re: OnStart does not work consistently

Hi Shane, 

 

I actually created a "Welcome" page earlier. So it works for me in the Preview Mode but not on actual app. Do you have any idea why and how do I fix it? 

 

Thanks  

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

SecondImage

Follow PowerApps on Twitter

Stay Up-to-Date by following PowerApps on Twitter

Top Community Contributors for July 2019

Top Community Contributors for July 2019

Let's thank our top community contributors

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

FifthImage

Dynamics 365 and Power Platform April 2019 Release notes

Features releasing from April 2019 through September 2019!

Users Online
Currently online: 73 members 3,920 guests
Please welcome our newest community members: