cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Brammers
Level: Powered On

PowerApps Flow error when using iOS App

Hi All, just noticed a problem with an app i've created recently.

 

The app itself has multiple data sources in SharePoint, and also connects to Office365 etc etc.

 

At certain points, it triggers a Flow, and this is where the error happens.

 

If i run the app from within PowerApps (i.e for testing), or if I open the app in the browser, there are no issues - everything happens as it is supposed to. The app talks to Flow, flow updates sharepoint, flow creates or deletes calendar events exactly as I want it to.

 

Unfortunately, when I perform exactly the same actions when using the iOS app, I get the following error -

 

Unable to process template language expressions in action 'Create_Calendar_Entry' inputs at line '1' and column '1922': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_office365']['connectionId']' cannot be evaluated because property 'shared_office365' doesn't exist, available properties are 'shared_sharepointonline'. Please see https://aka.ms/logicexpressions for usage details.'.

 

I have trialed this extensively under many different conditions, and the error ONLY occurs when using iOS and the Win10 application.

 

Any thoughts?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: PowerApps Flow error when using iOS App

Hi @Brammers ,

Could you please share a screenshot about your flow's configuration?

Could you show more details about the formula you used to fire your flow within your app?

 

Based on the error message that you mentioned, it seems to tell that there is something wrong with the Office 365 Outlook connection you added within your app.

The user @Anonymous has faced similar issue with you, please check the response within the following thread:

https://powerusers.microsoft.com/t5/General-Discussion/flow-launched-from-powerapps-error/td-p/43399

 

On your side, please consider remove the flow connection from your app, and then re-add it, save your app, then run this app within your iOS device, check if the issue is solved.

 

If the issue still exists, please consider re-add a new connection to your Office 365 Outlook within your flow, and use the new connection for your 'Create_Calendar_Entry' action. Then when you run your app within your iOS device, please provide proper credentials for the Office 365 Outlook connection.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
4 REPLIES 4
Community Support Team
Community Support Team

Re: PowerApps Flow error when using iOS App

Hi @Brammers ,

Could you please share a screenshot about your flow's configuration?

Could you show more details about the formula you used to fire your flow within your app?

 

Based on the error message that you mentioned, it seems to tell that there is something wrong with the Office 365 Outlook connection you added within your app.

The user @Anonymous has faced similar issue with you, please check the response within the following thread:

https://powerusers.microsoft.com/t5/General-Discussion/flow-launched-from-powerapps-error/td-p/43399

 

On your side, please consider remove the flow connection from your app, and then re-add it, save your app, then run this app within your iOS device, check if the issue is solved.

 

If the issue still exists, please consider re-add a new connection to your Office 365 Outlook within your flow, and use the new connection for your 'Create_Calendar_Entry' action. Then when you run your app within your iOS device, please provide proper credentials for the Office 365 Outlook connection.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Brammers
Level: Powered On

Re: PowerApps Flow error when using iOS App

Hi Kris,

 

I ended up having to remove all the flow steps using an outlook connection, then removing the connection itself, removing the flow connections from the powerapp, then adding it all again in reverse order - then it started working OK!

 

Thanks for pointing me in the right direction.

Brammers
Level: Powered On

Re: PowerApps Flow error when using iOS App

Well, it worked for a couple of hours - but now the same problem is back!

 

I haven't made any changes to the app or the flows, and now it is failing again when using the iOS app.

 

All works OK from web browser or testing within the studio though.

 

Can this be escalated to MS PowerApps team? There is obviously a serious bug somewhere.

digiservice
Level: Power Up

Re: PowerApps Flow error when using iOS App

I am having the same issue and it is driving me nuts. The connection will work with successful flows maybe one or two times then start erroring. Something isn't right here for these connections to be dropping. I have rebuilt several flows, several times, only for them to work a few times, then error.

 

I have rebuilt the flow, reconnected in the app, republished the app. Works a few times, then will error.

 

I have saved a copy of the flow, reconnected in the app, republished the app. Works a few times, then will error.

 

Nearly always errors on either the first Outlook connector or the first Sharepoint connector.

 

Please can this be investigated? It's making flow virtually unusable with powerapps.