cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
TJL
Level: Powered On

PowerApps Postgres Connection failing for Azure Hosted PostgreSQL, same gateway & DB works for PowerBI

Hi all, 

 

I'm trying to create a PowerApps Connection to an Azure Hosted PostgreSQL Database using an exisiting On Premises Data Gateway. The same Gateway is currently used by PowerBI Pro to connect to the same database on the same server and it works fine.

 

When trying to make the connection via Powerapps Connection screen it fails, saying: Credentials are missing or not valid. inner exception: The credentials provided for the PostgreSQL source are invalid. (Source at servername.postgres.database.azure.com;databasename.) clientRequestId: 

 

Creds have been checked 100 times. 

 

Powerapps can use the same gateway to connect to a non-azure hosted postgres instance that doesn't require the username to be in the username@serverhostname format. 

 

I'm not sure if its a bug with the PowerApps Postgres connector that is in preview or the gateway

 

Looking for ideas, throughts, directions or places to file bugs for PowerApps Connectors

 

TJL

2 REPLIES 2
Community Support Team
Community Support Team

Re: PowerApps Postgres Connection failing for Azure Hosted PostgreSQL, same gateway & DB works for PowerBI

Hi @TJL ,

 

After some research, it seems that so far there is no document published for PostgresSQL about the connecting steps.

Please check if below thread could help:

https://powerusers.microsoft.com/t5/General-Discussion/Postgres-connection/td-p/63839

 

Regards,

Mona

 

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
TJL
Level: Powered On

Re: PowerApps Postgres Connection failing for Azure Hosted PostgreSQL, same gateway & DB works for PowerBI

Hi Mona, 

 

I have reviewed that documentation but I'm not using ODBC, I'm using NPGSQL (https://www.npgsql.org). The same gateway (using NPGSQL) on same machine works perfectly for PowerBi to connect to Azure Hosted PostgreSQL but not when using the PowerApps connector via the same gateway.

 

I found this documentation: https://docs.microsoft.com/en-us/connectors/postgresql/ ,but under https://docs.microsoft.com/en-us/connectors/postgresql/#creating-a-connection it just refers to entering a username and doesn't mention the format.

 

I think the connector doesn't support usernames in the username@serverhostname format that Azure Hosted PostgreSQL uses or doesn't pass the information correctly to the On Premise gateway. 

 

I can PowerApps connector via the same gateway to connect to a local PostgreSQL instance that doesn't use the username@serverhostname format, but that doesn't help me connect to Azure Hosted PostgreSQL! Smiley Sad

 

Anything else you can suggest? Or any one else we can send this to? 

 

Regards,

 

TJL

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Users Online
Currently online: 78 members 4,460 guests
Please welcome our newest community members: