cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
iamandyf
Level: Powered On

PowerApps sending Email to last form recipient

I've very recently started using PowerApps and my first test was taking the Support Request Template and altering it to better fit my organisation. 

 

One of the changes i've made is to allow admin users to submit forms on behalf of other users. When admins do this, they have the option to update the task status of the call to "COMPLETED". This essentially just removes some of the faff that we would have to do (create the ticket, go back to the menu screen, find the ticket, edit the ticket), and also means users will recieve less emails. 

 

The problem i've encountered is that when we mark the form as "COMPLETED", the call is added to our SharePoint list and it appears as completed, however the flow that sends the email resends the previous ticket created to the previous user instead of sending the new ticket.  

 

(E.g. John Smith is an admin and created a ticket at 12:00 on behalf of "User A". "User A" is sent a confirmation ticket upon creation of the ticket with some of the ticket details. 
John Smith then creates another ticket at 12:30 on behalf of "User B" and this time marks it as complete. Flow then resends the first ticket to "User A", then sends the new ticket to "User B".)

 

All I have done is set the default "Task Status" card (from the "Help Desk" template) to visible for admin users. 

 

The flow is also the same as the one created in the "Help Desk"  template.

 

To make it even more frustrating, when I preview the app in the editing page, it works perfectly. When I publish the app, the above issue occurs. 

 

Any insight as to why this may be happening would be much appreciated.

3 REPLIES 3
Lisabel0
Level 8

Re: PowerApps sending Email to last form recipient

Administrator
Administrator

Re: PowerApps sending Email to last form recipient

hi @iamandyf please review the above response and reply back if you need further assistance. 

 

Thank you. 

 

@TopShelf-MSFT

iamandyf
Level: Powered On

Re: PowerApps sending Email to last form recipient

Hello, 

 

Thank you for your response. 

 

I have reviewed the guidance you sent but unfortuantely it hasnt helped with the issue i am encountering. 

 

The powerapp is 99% working. The only fault is when I unhid the "Task Status" field on the ticket creation page. If the value if changed from "Not Started", the flow does not function properly.  

 

For example, I have just created a new ticket which was given the auto ID value of "252". I marked this ticket as "Completed" from the ticket creation page as I had unhid the "TASK STATUS" selector (which is hidden by default). however instead of the flow running with the value of the ticket that was just created (252), the flow ran using the ID of the last ticket I created, which in this case had the ID 210.  

 

Happy to provide any screenshots as requried if that would make this easier to understand. 

 

Many Thanks,

Andrew.

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Top Community Contributors for July 2019

Top Community Contributors for July 2019

Let's thank our top community contributors

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

FifthImage

Dynamics 365 and Power Platform April 2019 Release notes

Features releasing from April 2019 through September 2019!

Users Online
Currently online: 168 members 5,341 guests
Please welcome our newest community members: