cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TomUserPowerapp
Level: Powered On

Problem when I publish the app I can't navigate

Hello,

 

I'm creating an app with some screens with some components, and a MySQL database.

I have first Menu Components, where I have on output selection of the menu in number (like 0, 1, 2, …) and a boolean for know if something is selected on the menu.

And a second components name dialogBox same of the reusables components presents by Microsoft.

I use in screens a toggle event with a switch, when the users select something on the menu,

The toggle activates, the function activates and directs it to the screen it has chosen. It works in development mode on powerapps studio but once share, the navigation bug and no longer works. After several tests, the toggle is activated well but I do not stop to determine the real problem, I feel that the dialog box sometimes blocks this navigation once shared.

I remember that the app launched in development works but not once it is published and shared. It seems like the application freeze in publish when I click on the menu.

 

Does anyone have the same problem?

 

Thanks to the community and support help desk.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Administrator
Administrator

Re: Problem when I publish the app I can't navigate

Moving article to creating apps


@ToddTrotter  @TomUserPowerapp  @aorphan  @TopShelf-MSFT 

3 REPLIES 3
aorphan
Level: Powered On

Re: Problem when I publish the app I can't navigate

Yes, we are experiencing a similar issue. App works fine in edit mode, but doesn't work properly after publishing in play mode. Screens 1 & 2 work and render properly, but none of our other screens work. What gives??

ToddTrotter
Level: Powered On

Re: Problem when I publish the app I can't navigate

Hey Folks, 

 

Please move this question to the following Forum:  

 

https://powerusers.microsoft.com/t5/Creating-Apps/bd-p/PA_Creating_Apps 

 

Unfortunately, I am not able to move it myself.   The folks monitoring that forum can help.

 

Todd

Highlighted
Administrator
Administrator

Re: Problem when I publish the app I can't navigate

Moving article to creating apps


@ToddTrotter  @TomUserPowerapp  @aorphan  @TopShelf-MSFT