Showing results for 
Search instead for 
Did you mean: 
Level: Powered On

Returning and array to Powerapps using the Response Method

Hi - I wonder if anyone can help me. I'm just trying out the suggested method for returning an array into Powerapps, and I appear to have a slight issue. Link for blog article:



Firstly, I have adapted the method to replace the "Execute a SQL Query" action wtih a "Execute SQL Stored Procedure" action as the the former action wasn't allowed using a gateway to an on prem DB. However I believed I had all but succeed in this as when I tested the flow (consisting of a Powerapps Trigger; an Execute SQL Stored Procedure; and a Reponse).


I set up the Body formula as advised (body('execProc').ResultSets.Table1) and set the Schema from the results of the stored procedure. When I tested this the first time the flow executed successfully, the Stored Proc returned an array of data and the output section of the 'Response' Action had a body containing the array in JSON format. When I continued with the method using the ClearCollect(searchResults, execProcFlow.Run()), I noticed that the collection returned was just the value "True". When I fiddled about a bit an tried rebuilding the flow I've noticed that he first time the flow runs after being set up it works as expected, however on all subsequent executions (which show as succesful) they have not Output section in the Response Action and have the message: 


ActionResponseSkipped. The execution of template action 'Response' is skipped: the client application is not waiting for a response from service


I'm assuming that this is why the response fed into Powerapps is merely "True". Does anyone know what the above message is indicating is wrong and why this might work on the initial execution but not on subsequent executions.




Level 8

Re: Returning and array to Powerapps using the Response Method

I suggest that you could open a ticked in

Level 8

Re: Returning and array to Powerapps using the Response Method



I got the exact same problem and can't use your support link. 'Canada'


Other related posts: #1, #2


#1 has a good desciption of the issue and for some reason, said it was solved. 


This is the OUTPUTS of my Response tile in Flow.



I'm using 


And all i get is 'True'. This used to work, what changed?

Level 8

Re: Returning and array to Powerapps using the Response Method

Still doesn't work...

Tried with another connection too.

Level: Powered On

Re: Returning and array to Powerapps using the Response Method

I currently get the correct field names in the collection, but no data (even though when testing the flow, I get the correct data in the output).

Helpful resources


Watch Sessions On Demand!

Continue your learning in our online communities.


PowerApps Monthly Community Call

Next Wednesday, August 21st at 8am PDT

Top Community Contributors for July 2019

Top Community Contributors for July 2019

Let's thank our top community contributors

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020


Power Platform World Tour

Coming to a city near you


PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!


Join PowerApps User Group!!

Connect, share, and learn with your peers year-round


Dynamics 365 and Power Platform April 2019 Release notes

Features releasing from April 2019 through September 2019!


Power Summit Australia 2019

August 20-23rd 2019

Users Online
Currently online: 45 members 4,117 guests
Please welcome our newest community members: