cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
JimmyAinsley
Level: Powered On

Screen's OnVisible event is not fired the first time navigating to it

Hi everyone,

 

I have come across a very weird bug here.

 

This is the code on one of my screen's OnVisible attribute:

UpdateContext({
     ShowSomeDialog:false,
     SomeText:"Hi!"
})

When I navigate to this screen, my pop-up with the Visible attribute set to ShowSomeDialog is visible even though it should be set to false, and my label with the Text attribute set to SomeText is empty.

 

BUT, if I go to the previous screen and navigate to my problematic screen again, this time the OnVisible event seems to be triggered correctly.

 

The button that navigates to this problematic screen is a very simple Navigate function with nothing else:

 

Navigate(MyBuggedScreen, ScreenTransition.Fade)

 

Another weird thing about this situation is the fact that the application works perfectly when launched in 'Edit' mode, but has this bug when launched via 'Play' mode or via my cell phone.

 

What I've tried:

- Duplicating the screen and navigating to this new one instead of the original one (same bug);

- Using 'Save As' to create a new copy of my app (same bug);

 

 

I have no idea where to look next, any suggestions are welcome!

 

Thanks!

1 REPLY 1
Community Support Team
Community Support Team

Re: Screen's OnVisible event is not fired the first time navigating to it

Hi @JimmyAinsley,

Do you initialize the ShowSomeDialog variable and SomeText variable in other place within your app?

 

I have made a test on my side, and don't have the issue that you mentioned. The screenshot as below:

1.JPG4.JPG2.JPG3.JPG

The GIF screenshot as below:Test1.gif

 

Please take a try to re-create your app, and then check if the issue is solved.

If the issue still exists, please take a try with the following workaround:

Set the OnVisible property or OnStart property of the first screen of your app to following formula:

UpdateContext({
     ShowSomeDialog:false,
     SomeText:""
})

Set the OnSelect property of the "Navigate" button to following:

Navigate(MyBuggedScreen, ScreenTransition.Fade)

Set the OnVisible property of the MyBuggedScreen to following:

UpdateContext({
     ShowSomeDialog:false,
     SomeText:"Hi!"
})

then check if the issue is solved.

 

Best regards,

Kris

 

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 53 members 4,694 guests
Please welcome our newest community members: