cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
akario
Level: Powered On

Submit Form not working on dynamic data source

I have datasource from excel serveral tables.
and I datasource of from as dynamic table link to dropdown.

but when I save data by SubmitForm(Form1). It's not working.

1 ACCEPTED SOLUTION

Accepted Solutions
akario
Level: Powered On

Re: Submit Form not working on dynamic data source

Oops! sorry it's working fine

 

able to submit form now.

 

After I changed to assigned table with Set(tb,switch(...))

Previously I have assigned table by store multi tables in Collection.

4 REPLIES 4
shailendra74
Level 8

Re: Submit Form not working on dynamic data source

Hi @akario 

 

Is the Edit Form mapped on a single table for insert/update or how is it.

 

If its Edit Form, can you check the DataField & Update Properties of the DataCard.

 

Thanks.

Community Support Team
Community Support Team

Re: Submit Form not working on dynamic data source

Hi @akario ,

Please check:

1)whether the excel file was opening when you submitted the form?

2)did you set the right property to the dropdown?    (DropDown1.Selected.fieldname)

Do you have any error message?

Could you show your screenshoots or the settings of the form?

 

 

Best regards,

Community Support Team _ Phoebe Liu

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
akario
Level: Powered On

Re: Submit Form not working on dynamic data source

Show error message below

"There was a problem saving your changes. The data source may be invalid"

 

Due to I assigned table with below fx
Set(TBSc,Switch( LabelTable.Text,"Sb01",Tb01,"Sb02",Tb02,...)

 

and then I have set Data Source of EditForm1 as TBSc

 

once I run SubmitForm(EditForm1) 
the message above occure

akario
Level: Powered On

Re: Submit Form not working on dynamic data source

Oops! sorry it's working fine

 

able to submit form now.

 

After I changed to assigned table with Set(tb,switch(...))

Previously I have assigned table by store multi tables in Collection.

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 173 members 4,292 guests
Please welcome our newest community members: