cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
MichelleWongNL
Level: Powered On

Submit a Powerapp Form keeps loading with dots... after 5 mins the Form submits. Is this an performance issue?

Hi all, 

 

I made a PowerApp Form in one of my SharePoint lists. When I want to submit my form input, it keeps loading ... and I only see dots above the Form moving.... After 5 minutes the Form submits and get saved into my SharePoint list. 

dots.PNGForm keeps loading...... after 5 mins submit into shp listform.PNGMy PowerApp Form

 

My question, is this an Performance issue? Everything on our side (also internet) seems okay. 

Or is there any settings in my PowerApps Form what I have missed to let the Form submits directly?? (onSave: SubmitForm(SharePointForm1 already in the App) 

 

Ofcourse Submitting a Form input and wait for 5 minutes is not acceptable, right? 

 

Any help should be fine! Thx in Advanced.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
MichelleWongNL
Level: Powered On

Re: Submit a Powerapp Form keeps loading with dots... after 5 mins the Form submits. Is this an performance issue?

Hi Mona, 

 

Yesterday I tried to test again and everything seems works fine. The PowerApp form summits directly! So, I think this is an ‘internet’ hickup or so? Already tried a few days, also looking for many debugging and analysing methods.... and couldnt find. Finally tried to do a post in the community and asking for help via Twitter.... 

And now, it suddenly works Woman Sad

Anyways, many thanks for the willing of help! 

 

2 REPLIES 2
Community Support Team
Community Support Team

Re: Submit a Powerapp Form keeps loading with dots... after 5 mins the Form submits. Is this an performance issue?

Hi @MichelleWongNL ,

 

Please try to test with another list and another device. If the issue is specific to this list, then please check how many columns do you have for this form and is there any unusual column type or special setting in this list?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
MichelleWongNL
Level: Powered On

Re: Submit a Powerapp Form keeps loading with dots... after 5 mins the Form submits. Is this an performance issue?

Hi Mona, 

 

Yesterday I tried to test again and everything seems works fine. The PowerApp form summits directly! So, I think this is an ‘internet’ hickup or so? Already tried a few days, also looking for many debugging and analysing methods.... and couldnt find. Finally tried to do a post in the community and asking for help via Twitter.... 

And now, it suddenly works Woman Sad

Anyways, many thanks for the willing of help! 

 

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 42 members 4,530 guests
Recent signins:
Please welcome our newest community members: