cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
meganschu
Level: Powered On

Re: mailto command is adding "+" characters to my message

Interesting. It worked perfectly for me. It's launching in the mail app on iOS.

 

Thanks!

Microsoft Employee

Re: mailto command is adding "+" characters to my message

@NK-CSC I tried with the &subject rather than ?subject but iOS Mail just jams the whole thing into the To: line.

 

Launch("mailto:support@email.com&subject=Help with My App")

 

results in:

 

To: mailto:support@email.com&subject=Help with My App

Subject: [blank]

JC75
Level: Powered On

Re: mailto command is adding "+" characters to my message

Any update on this?

 

if using Launch("mailto:email@email.com?subject=Something goes here")

 

It opens mail(on win 10 =) and works but as the + in between the words for subject.

 

if using Launch("mailto:email@email.com&subject=Something goes here")

 

it opens mail(on win 10) but it just ends up with the email addrees including the subject wording all as one and no subject line.

 

 

Highlighted
Anonymous
Not applicable

Re: mailto command is adding "+" characters to my message

 

The Launch command takes optional parameters in the following format;

 

Launch("address", "name", "value", "name", "value"....)  where name/value pairs are queries passed to a web URL.

 

We tend to put the whole "mailto:blahblah?subject=etc" into the address field, when actually you should use the Launch optional query parameters to pass in what you need, so;

 

address is the URL containing the mailto command and email address

Each name/value pair is a query parameter with it's value

 

Example:

 

Launch("mailto:bobjones@home.com", "subject", "Here's a subject line", "body", "Hello,

How are you?



Line breaks are just carriage returns and spaces remain spaces!")

 

I've tested this with Chrome and Edge (Edge was giving me headaches originally) and it works fine.  I haven't tested all the RFC stated parameters or attachments yet but this works and no annoying +'s!

 

Hope this helps someone

 

Kind regards,


R

jvargas
Level: Powered On

Re: mailto command is adding "+" characters to my message

THIS IS THE SOLUTION, THANKS!!!


@Anonymous wrote:

 

The Launch command takes optional parameters in the following format;

 

Launch("address", "name", "value", "name", "value"....)  where name/value pairs are queries passed to a web URL.

 

We tend to put the whole "mailto:blahblah?subject=etc" into the address field, when actually you should use the Launch optional query parameters to pass in what you need, so;

 

address is the URL containing the mailto command and email address

Each name/value pair is a query parameter with it's value

 

Example:

 

Launch("mailto:bobjones@home.com", "subject", "Here's a subject line", "body", "Hello,

How are you?



Line breaks are just carriage returns and spaces remain spaces!")

 

I've tested this with Chrome and Edge (Edge was giving me headaches originally) and it works fine.  I haven't tested all the RFC stated parameters or attachments yet but this works and no annoying +'s!

 

Hope this helps someone

 

Kind regards,


R


 

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 100 members 4,158 guests
Please welcome our newest community members: