cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Kuehnel98
Helper I
Helper I

Problems after Power Apps Portal was automatically deleted

Hello everyone!

 

I ran into some problems after my Power Apps (trial) Portal - lets call it Portal A - was automatically deleted after 30 days. I then created a new Portal - lets call it Portal B - in the same environment using the Website data of the Portal which was deleted before. Just for the record: the environment in question is a sandbox (development) environment.

 

Until this point no problem.

 

Now 3 problems arose:

 

(1) I enabled the SharePoint integration for Portal B through the Portal Admin Center. The SharePoint integration for my table "Contractlist" was already set up because I already did this some time ago. I also double and triple checked that the SP integration for my table was properly set up. Then I got this error. In Portal A with the same options and settings everything worked fine. I did neither change anything of the settings nor anything in the Portal Management App.

 

Kuehnel98_0-1669367620031.png

 

(2) When I want to edit the Basic Forms or Advanced Forms in the Portal Management App, I get this Script Error.

I changed the URL for my org to "myorg" for safety reasons.

One of the scripts for this record has caused an error. For more details, download the log file.

Web resource method does not exist: adx.xrm.webForms.entityForm.onLoad. However the closest object we found is adx that contains these properties: resources,adx_bingmaps,adx_entityform. Please verify this object is not corrupt and is not an object of the same name defined elsewhere, such as another script.

at y._handleMethodNotExistError (https://myorg.crm16.dynamics.com/uclient/scripts/app.js?v=1.4.5009-2211.1:2081:5114)
at y.execute (https://myorg.crm16.dynamics.com/uclient/scripts/app.js?v=1.4.5009-2211.1:2081:3702)
at https://myorg.crm16.dynamics.com/uclient/scripts/app.js?v=1.4.5009-2211.1:164:26973
at i (https://myorg.crm16.dynamics.com/uclient/scripts/app.js?v=1.4.5009-2211.1:351:88)
at ee._executeIndividualEvent (https://myorg.crm16.dynamics.com/uclient/scripts/app.js?v=1.4.5009-2211.1:164:26947)
at ee._executeEventHandler (https://myorg.crm16.dynamics.com/uclient/scripts/app.js?v=1.4.5009-2211.1:164:23952)
at Object.execute (https://myorg.crm16.dynamics.com/uclient/scripts/app.js?v=1.4.5009-2211.1:164:21169)
at N._executeSyncAction (https://myorg.crm16.dynamics.com/uclient/scripts/app.js?v=1.4.5009-2211.1:970:692)
at N._executeSync (https://myorg.crm16.dynamics.com/uclient/scripts/app.js?v=1.4.5009-2211.1:970:419)
at N.executeAction (https://myorg.crm16.dynamics.com/uclient/scripts/app.js?v=1.4.5009-2211.1:970:201)

 

Session Id: e93a3f43-879d-4dae-8fb2-e748686f8612

Correlation Id: 2da89b70-0c34-4ecb-bf2d-3127ac74f1b8

Event Name: onload

Function Name: adx.xrm.webForms.entityForm.onLoad

Web Resource Name: adx_webforms/adx.xrm.webforms.handlers.js

Solution Name: MicrosoftPortalTimeline

Publisher Name: adxstudio

Time: Fri Nov 25 2022 10:00:15 GMT+0100 (Central European Standard Time)

 

(3) When I want to create or edit Basic/Advanced Forms, I cannot change or select

- Table Name

- Form Name

-Tab Name

 

Normally it should look like this:

Kuehnel98_1-1669368304950.png

 

Web resource method does not exist: adx.xrm.webForms.entityForm.onLoad. However the closest object we found is adx that contains these properties: resources,adx_entityform,adx_bingmaps. Please verify this object is not corrupt and is not an object of the same name defined elsewhere, such as another script.Session Id: 7f62540a-3bbe-43be-9700-9b50cd97abe6Correlation Id: 30a72441-574d-4f97-8b5a-25a12f946d6fEvent Name: onloadFunction Name: adx.xrm.webForms.entityForm.onLoadWeb Resource Name: adx_webforms/adx.xrm.webforms.handlers.jsSolution Name: MicrosoftPortalTimelinePublisher Name: adxstudioTime: Fri Nov 25 2022 10:15:22 GMT+0100 (Central European Standard Time)

But in the Portal Management of Portal B it looks like this:

Kuehnel98_2-1669368399227.png

The fields to select Table Name etc. are missing. Might this be connected to the Script error?

 

I think the problems have something to do with the automatic deletion of Portal A - this might have screwed things up. Is there a way to set things back in order? Help is highly appreciated. Thank you!

 

Kind regards.

2 ACCEPTED SOLUTIONS

Accepted Solutions
ragavanrajan
Super User
Super User

Hi @Kuehnel98 

 

Try this way. Because you mentioned you have changed the URL. Try the portal restart (not reset)  and clear the cache 

Official URL to restart the site: 

 

To clear cache: 

 

https://ragavanrajan.medium.com/powerapps-portal-finding-current-version-or-clear-portal-cache-901e6... 

 

If the above two don't work then you may need to raise a support ticket with the helpdesk team. 

Official URL here: 

 

 

Hope it helps. 
------------

If you like this post, give it a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users to find it.

 

 

 

View solution in original post

I found a solution to problem (2) and (3) in another forum post. It was pretty basic:

 

It was the browser AddOn AdBlock which inhibited the Portal Management App from working properly. After i deactivated the AddOn for the Portal Management URL everything works fine.

 

For a more detailed description:

https://powerusers.microsoft.com/t5/Power-Apps-Portals/Script-error-keeps-popping-up-in-Portal-Manag...

 

See also the blogpost of Oliver Rodrigues:

https://oliverrodrigues365.com/2020/07/31/power-apps-portals-script-error-one-of-the-scripts-for-thi...

 

Thanks for the help once again @ragavanrajan 

View solution in original post

3 REPLIES 3
ragavanrajan
Super User
Super User

Hi @Kuehnel98 

 

Try this way. Because you mentioned you have changed the URL. Try the portal restart (not reset)  and clear the cache 

Official URL to restart the site: 

 

To clear cache: 

 

https://ragavanrajan.medium.com/powerapps-portal-finding-current-version-or-clear-portal-cache-901e6... 

 

If the above two don't work then you may need to raise a support ticket with the helpdesk team. 

Official URL here: 

 

 

Hope it helps. 
------------

If you like this post, give it a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users to find it.

 

 

 

Thank you so much @ragavanrajan ! Resetting the portal worked like a charm, at least for the SharePoint integration. You saved my day 🙂

 

The problem with the Script error still remains. I can't change some of the Form options in the Portal Management App either. Additionally, when I want to create Basic Form Meta Data, there is a similar script error but with a different error message (I can't create Basic Form Meta Data for Portal B):

Kuehnel98_0-1669707858044.png

Web resource method does not exist: adx.xrm.webForms.entityFormMetadata.type.onChange. However the closest object we found is adx that contains these properties: resources. Please verify this object is not corrupt and is not an object of the same name defined elsewhere, such as another script.

Session Id: dbd8eede-48c2-44e7-924a-7bf392b56467

Correlation Id: 6210015c-198c-4958-ad89-a7b1cdd59b9f

Event Name: onchange

Function Name: adx.xrm.webForms.entityFormMetadata.type.onChange

Web Resource Name: adx_webforms/adx.xrm.webforms.handlers.js

Solution Name: MicrosoftPortalTimeline

Publisher Name: adxstudio

Time: Tue Nov 29 2022 08:42:16 GMT+0100 (Central European Standard Time)

 

It seems to me that something broke when Portal A was automatically deleted.

I found a solution to problem (2) and (3) in another forum post. It was pretty basic:

 

It was the browser AddOn AdBlock which inhibited the Portal Management App from working properly. After i deactivated the AddOn for the Portal Management URL everything works fine.

 

For a more detailed description:

https://powerusers.microsoft.com/t5/Power-Apps-Portals/Script-error-keeps-popping-up-in-Portal-Manag...

 

See also the blogpost of Oliver Rodrigues:

https://oliverrodrigues365.com/2020/07/31/power-apps-portals-script-error-one-of-the-scripts-for-thi...

 

Thanks for the help once again @ragavanrajan 

Helpful resources

Announcements
Carousel Community Blog

Check out the Community Blog

Read all about the most recent blogs in the community!

Community Call Conversations

Introducing the Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Carousel News & Announcements

What's New in the Community?

Check out the latest News & Events in the community!

Users online (1,861)