cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
SleekDan
Level: Powered On

Action 'Start an approval' failed

Whenever i add a 'start an approval step' to a flow it seems to fail. I have a very basic scenario i want to implement. When a document is added to a library, an approval is requested, when the approval response is given, the approval status is set to approved or rejected.

 

Right now the flow trggers fine, but when it gets to the 'start an approval' step, it tries to run for about 3 minutes an then errors. No email is recevied by the approver, and no further steps are completed.

 

This environment is new (office 365 Business Premium), but couple of weeks new, so everything should have completed provisioning. And I've also tried on another several month old envrionment and get the same issue.

 

The error message is very unhelpful:

 

429. The request failed. Error code: 'CommonDataModelNamespaceNotProvisioned'. Error Message: 'A Common Data Service database has not been provisioned for environment <GUID>, or is currently being provisioned.'.

 

Any help would be greatly appreciated.

 

Capture.JPGCapture1.JPG

 

1 ACCEPTED SOLUTION

Accepted Solutions
SleekDan
Level: Powered On

Re: Action 'Start an approval' failed

Finally!

 

After months of waiting it is now possible to create a default database again. I think this is due to microsoft' recent announcements about the CDS upgarde.

 

If you are having the same problem you will need to be a global admin and then do the follwoing:

  • Get an F2 flow licence for the account you are using
  • Go to the flow app and then from settings choose the admin centre
  • choose the 'envronments' tab on the left
  • select your default environemnt
  • click 'create database' and follow the instructions

 

Now if you run a flow with an approval everything shoudl work!

9 REPLIES 9
Community Support Team
Community Support Team

Re: Action 'Start an approval' failed

Hi @SleekDan,

 

Thanks for sharing the detailed information. The error message says that a Common Date Service database has not been provisioned for this environment, do you have created a CDS data base for this environment?

 

If not, please create CDS database first in the environment then try again with it, please check this doc for more details on using environments within Microsoft Flow:

https://docs.microsoft.com/en-us/flow/environments-overview-admin

 

please feel free post back if you need more help.

 

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
SleekDan
Level: Powered On

Re: Action 'Start an approval' failed

Thanks Mabel,

 

We're on the right track but the problem persists...

 

So first off I was unable to check the 'environment' in the flow admin center! Even though i am a global admin and i have a business permium licence with flow included i had to add a flow p2 licence to be able to see the 'environment' tab in the flow admin center.

 

So once i can see the environments i can in fact see that no database has been created for my default environment. But when i try and create a database i get an error "Creating databases in default environments isn’t available right now, but will be back at a later date."

 

I've searched through a few forums and can't find any help or any info on when "later" might be. Some posts were from the beginning of 2018 so it's already been a few months!

 

Capture2.JPG

 

So i am now in the position of not being able to use approvals in any flows for my entire tenant, until i can create a database, which is not possible until "later".

 

Any ideas??

gmajsterek
Level: Power Up

Re: Action 'Start an approval' failed

I have the same issue, Flow Plan 2 license (trial), suprisingly it works fine in other tenant which i believe is configured the same  way.

SleekDan
Level: Powered On

Re: Action 'Start an approval' failed

I contacted MS support and they've told me it's because I'm in the UK. In the UK it is not possible to create a Common Data Service right now.

 

So that means you cannot create a database for the default flow environment, which mean no approvals will work for any flows!

 

This will be the case for a minimum of 1 month, and there is no estimate of when it might be fixed, so it could be 1 month from now, or 5 years from now.

 

The advice from MS support is to create a second environment in flow as you are able to create a database there. Though i think you need extra flow licences to use secondary environments.

 

 

westerdaled
Level: Powered On

Re: Action 'Start an approval' failed

Hi

 

Yep,  I am gettng  same issue here on a dev tenant. Are we honesly expected to ceate a CDS for something so trvial as a Page Approval Flow?   

 

 

Update:  just seen this, it looks like it is being addressed in all tenants created in the UK after March 2018 ( and worringly this before brexit!)

 

https://techcommunity.microsoft.com/t5/SharePoint/Announcing-SharePoint-page-approvals/td-p/215466

SleekDan
Level: Powered On

Re: Action 'Start an approval' failed

Finally!

 

After months of waiting it is now possible to create a default database again. I think this is due to microsoft' recent announcements about the CDS upgarde.

 

If you are having the same problem you will need to be a global admin and then do the follwoing:

  • Get an F2 flow licence for the account you are using
  • Go to the flow app and then from settings choose the admin centre
  • choose the 'envronments' tab on the left
  • select your default environemnt
  • click 'create database' and follow the instructions

 

Now if you run a flow with an approval everything shoudl work!

Bredonkulous
Level: Power Up

Re: Action 'Start an approval' failed

@SleekDan What are you seeing in your environment? I dont see anything that you're describing (in my dev environment with preview features enabled). 

 

My Left Navigation for Flow Admin Center

Data Policies

    Tenant

     User Licenses

     Quotas

BlueCar
Level: Powered On

Re: Action 'Start an approval' failed

@Bredonkuloushave you figured it out?

Do you have the F2 flow licence active for your user, that is accessing the admin portal?

DavePotts_BritE
Level: Powered On

Re: Action 'Start an approval' failed

FYI only: I've just seen the same symptoms apprear after we did work on our Dynamics 365CE environment. It seemed to get the Flow in an unhappy state. Redployment of the Flow (package zip) fixed the problem.

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Users Online
Currently online: 55 members 4,863 guests
Please welcome our newest community members: