cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
colonel_claypoo
Level: Powered On

Apply to each action times out after 10 minutes

Hi,

 

I have the output of a Select action go through an Apply to each action.

Inside the loop there's a condition checking if the current item (a user) has a specific email extension. If true the nex action is the Get manager (V2) action.

 

There're 828 items in the array that the Apply to each action has to loop through but the flow times out after 10 minutes and I can't figure why that might be.

 

2.png

 

Here's the Flow for your reference (I pixelated those actions that have 1.png

 

I couldn't find anything in the documentation mentioning that there's such a timout time for the Apply to each action.

 

Any ideas?

 

Thanks for your input.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Apply to each action times out after 10 minutes

Hi @colonel_claypoo,

 

Could you share all the screenshots of the Flow configuration?

You might consider filtering the items outside of Apply_to_each, such as using Get items-FilterQuery or Filter array.

This optimizes the number of actions to be executed in Apply_to_each, reducing execution time.

In addition, if it is not necessary, you do not need to add additional properties, such as "FiledValue", you could directly use the two properties DisplayName and Mail, Select action can also extract them.

Please take a try.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
7 REPLIES 7
Super User
Super User

Re: Apply to each action times out after 10 minutes

Hello @colonel_claypoo,

 

Is there a chance to see Flow run in more detail? There are some limits for Flow - https://docs.microsoft.com/en-us/flow/limits-and-config but Apply to each has just 100 000 runs limit.

P.

Highlighted
colonel_claypoo
Level: Powered On

Re: Apply to each action times out after 10 minutes

I think I isolated the action that causes the error. Without the Compose acton "FilteredManagersJSONObject" the Apply to each action succeeds after 14 minutes instead of throwing the error after 10. I find that quite peculiar and I will continue testing if one of the two dynamic variables used in the compose action could cause the error.

Community Support Team
Community Support Team

Re: Apply to each action times out after 10 minutes

Hi @colonel_claypoo,

 

Could you share all the screenshots of the Flow configuration?

You might consider filtering the items outside of Apply_to_each, such as using Get items-FilterQuery or Filter array.

This optimizes the number of actions to be executed in Apply_to_each, reducing execution time.

In addition, if it is not necessary, you do not need to add additional properties, such as "FiledValue", you could directly use the two properties DisplayName and Mail, Select action can also extract them.

Please take a try.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
colonel_claypoo
Level: Powered On

Re: Apply to each action times out after 10 minutes

@v-bacao-msft, thanks for your reply. I was able to get it to work but only with filtering down the items prior to the Apply to each action - like you suggested.

lreinhard7
Level 8

Re: Apply to each action times out after 10 minutes

Hi, This thread is almost 6 month old and I wonder if things have improved since then. I also face the situation that my flow times out after 10 min but I would need it to run much longer. The issue seems to be with the apply to each element. Is there something new that could help me increasing that time to 30 or 40 min? Note: I cannot filter or split up my data further and urgently need a longer time for each 'apply to each' runs. Would be great if somebody could provide some additional info/tipps/tricks. Many thanks and best regards, Ludwig

Tavi
Level: Powered On

Re: Apply to each action times out after 10 minutes

What I noticed is that after I get the timeout message, if I click on the left, on My flows then click on the name of the workflow , click on the run which says running I can see that the flow is still in progress , which is quite confusing because I am not sure if the 'Apply_to_each' is still running or it just increments in minutes without doing anything and eventually timing out for good.

 

ChrisBenJohnson
Level: Powered On

Re: Apply to each action times out after 10 minutes

I just had this issue - I noticed that the timeouts only occurred if I watched the Flow execute (in the view you see after selecting Test).

 

Testing the Flow and navigating to a different page means this error isn't seen.

 

As @Tavi  pointed out, it will still run, but seeing the error is very confusing. I was searching in vain for '10 minute Apply To Each timeouts' and now there obviously isn't such a thing!

 

You would only get this issue for Flows that take more than 10 minutes to complete, and if they take much longer you may not see that they have actually worked for some time. Mine take 30 minutes to finish, so between 10-30m I was wondering what was going on, then suddenly the email at the end of the Flow arrives!

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Users Online
Currently online: 296 members 5,032 guests
Please welcome our newest community members: