cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Rfla
Level 10

Condition problems?

Anyone else having problems with flows connected to SP lists or similar.

I have a very simple flow just to locate the problem.

 

Before I save the flow: (notice the Title column in the condition)

 

before.png

 

 

11 REPLIES 11
Rfla
Level 10

Re: Condition problems?

The post was cut.

Here the rest:

 

After i save the flow it shows this: notice the title column again:

after.png

Rfla
Level 10

Re: Condition problems?

The advanced condition shows : @contains(item()?['Title'], 'test')
Is this correct? Im used to seeing triggerBody() and not Item()?

Anyway the flow is not working.
Am I missing something basic? I tried to replace item with triggerBody.
Any yes the list have an item that has a title containing test. :-)
after_1.png

 

Microsoft Employee

Re: Condition problems?

Thanks for reporting this.

We already create a bug and the fix is on the way.

 

 

Highlighted
efialtes
Level 8

Re: Condition problems?

In the example given, and since the output from Sharepoint Get Items is an array... will the "Condition" block apply to each array item? Or do we need to use "Filter array" instead, and apply "Filter array output" as the input for "Apply To Each"?

 

BTW, the bug also happens with Array Filter; i.e. when you implement Recurrence trigger+Sharepoint Get Items+Array Filter.

 

Rfla
Level 10

Re: Condition problems?

Hi, has this been fixed?

Rfla
Level 10

Re: Condition problems?

@kkurni fix been deployed? :-) thanks for any feedback

Microsoft Employee

Re: Condition problems?

Yes, this should be fix now.

 

There was a problem with conditions for multi values which returned from GetItems Action.

The condition should be wrap inside for each.

 

You should see this flow instead.

(but if you still the old one, would you mind to try to recreate a new one ?)

 

Conditons get Items.png

Rfla
Level 10

Re: Condition problems?

Hmm seems to be adding a second for each as soon as I select a SP field to be added in either subject or body. And therefore not able to save it. If I drag the condition outside the first for each container, the flow is not taking into account the condition. It runs the action against all items/or none, regardless of the condition? Made a new flow. @kkurni

Microsoft Employee

Re: Condition problems?

I cannot repro this on my ends.

 

@Rfla, But does it work when you make a flow ?

 

Thanks

Rfla
Level 10

Re: Condition problems?

Ok In my last test I did it agains a SP list of type tasks. Will try the again agains a regular SP list and get back to you @kkurni

v-sheset
Level: Power Up

Re: Condition problems?

I am still facing the condition problem. It still does not seem to be working for me.

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020.

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Users Online
Currently online: 261 members 4,135 guests
Please welcome our newest community members: