cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
CMHants
Level: Powered On

Flow not sending email out from user

Hi Guys,

 

So my problem is probably simple but I cant seem to find the answer.  

 

Im triggering from an empty HTTP request made by a chatbot. My FLOW is needed to send an email to the users manager to let them know they are sick.

 

I can get the email to work alright but when I get different users to trigger the flow it still sends from my email address, it doesn't switch to the user address. Is there any way to get flow to switch user account.

5 REPLIES 5
Super User
Super User

Re: Flow not sending email out from user

Hey @CMHants 

 

 

Could you share a screenshot of your Flow and the connection that is used with the Send an Email step?

I think you will need to somehow catch the current user's email and put in a variable or something and then add in  the Send from (the field where you can put the email it has to be sent from) field.

Otherwise it will always be sent in your name because the step is using your account for the connection.

 

Hope this helps you a bit.

 

Kind regards

 

 

Tom





Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!





CMHants
Level: Powered On

Re: Flow not sending email out from user

thanks for your reply,

 

the HTTP request is made from a chatbot that picks up the users email address in the body

 

So I can get this to work if I could just decode the email address HTTP request, the @ symbol is changed into UTF -8 by flow and I dont know how to change it back.

 

If I could change the @ back from %40 to @ I could use the send mail connector in flow to send an email to the manager 

 

flow.PNG

Highlighted
CMHants
Level: Powered On

Re: Flow not sending email out from user

thanks for your reply,

 

the HTTP request is made from a chatbot that picks up the users email address in the body

 

So I can get this to work if I could just decode the email address HTTP request, the @ symbol is changed into UTF -8 by flow and I dont know how to change it back.

 

If I could change the @ back from %40 to @ I could use the send mail connector in flow to send an email to the manager 

 

flow.PNG

imoran
Level: Powered On

Re: Flow not sending email out from user

Use the Action "Send an email from shared mailbox" You'll obviously need Exchange permissions to send from this mailbox

 

Ian

 

Super User
Super User

Re: Flow not sending email out from user

Hey @CMHants 

 

 

There are some expressions that can decode and encode some UTF-8, I don't know the expressions out of my head.

But it's something like encode...().

So in your compose step search for the expressions to encode and replace maybe the %40?

 

Hope this helps a bit.

 

Kind regards

 

 

Tom





Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!





Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Users Online
Currently online: 215 members 4,251 guests
Recent signins:
Please welcome our newest community members: