cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flows stop triggering unexpectedly Bad gateway 502?

Hi, I've had a number of flows stop working all of a sudden with little information on what is at fault. The flows have been working fine and were not modified aroudn the time they stopped working. The only nugget to go off is the error 'bad gateweay 502' which is reported in a some of the recent failed runs.

 

I'm unable to trigger the flow (sharepoint new item is created or modified) so i'm stumped as to why it is not triggering. I've created a simple flow in the same account with the same trigger, that works the first time then doesnt work any more...

 

I've tried copying the flow to another account but that doesnt work more than once either!

 

I've tried copying the flow and deleting the original (because i was concerned there were quite a few instances of the flow running) but that didnt work either.

 

Really at a loss as to what is wrong and this is having a significant impact on our operations. if anyone has any pointers or guidance i'd appreciate hearing them.

 

The actions contained in the flow are:

Sharepoint update item

Sharepoint get items

Outlook send email

Outlook send email with options

 

Thanks,

Eddie

1 ACCEPTED SOLUTION

Accepted Solutions
JenVitug
Level 8

Re: Flows stop triggering unexpectedly Bad gateway 502?

Thanks, everything now back to normal Smiley LOL

View solution in original post

17 REPLIES 17
Community Support Team
Community Support Team

Re: Flows stop triggering unexpectedly Bad gateway 502?

Hi @Anonymous,

 

Could you please share a screenshot of your flow's configuration?

Could you please show a bit more about your error message?

 

I have made a test on my side and the "When an item is created or modified" trigger fires well. My flow's configuration as below:6.JPG

The flow works successfully as below:7.JPG

 

8.JPG

 

Please consider take a try to clear the cache of your browser and re-create your flow to check if the issue is solved.

 

In addition, please take a try to switch your flow's environment into another one and create same flow within it to check if the issue stills. If the issue doesn't exist in another environment, I think this issue is related to your flow's environment.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Re: Flows stop triggering unexpectedly Bad gateway 502?

hi @v-xida-msft

 

I've tried making a new flow with the same trigger and 1 action (send me an email) and that did not work either.

 

I dont think the complexity of the flow is an issue.

 

I'm trying to rule out parts of the problem today so i'll provide updates as i know more.

 

 

Thanks for the response, happy to take any other suggestions!
Eddie

 

(I Must confess, i created another post on the same issue before I knew some more about the issue https://powerusers.microsoft.com/t5/General-Flow-Discussion/Issue-with-flows-not-triggering-from-sha...)

 

Anonymous
Not applicable

Re: Flows stop triggering unexpectedly Bad gateway 502?

So, i've just re-tested it on the list thats been problematic (with just over a thousand items on it, with versioning on) and i've received a 502 error. Interestingly, the best way to see this error was to have the flow in the 'save' view and then trigger it in the background. When you do this you're presented with the error information but nothing is displated in the 'run history' view...

 

Here is the text from the failure

 

When an item is created or modified1sFailed

BadGateway.
INPUTS
Site Address
https://company.sharepoint.com/sites/
List Name
f9a8b7c8-2eda-47ab-a9a0-ca7c153803a2
OUTPUTS
Status code
502
Headers
KeyValue
Pragma
no-cache
x-ms-request-id
ba634a9e-5022-5000-fea6-4be4bd54071b;ba634a9e-3027-5000-fea6-44d09d89ba5b
Timing-Allow-Origin
*
Cache-Control
no-cache
Date
Wed, 14 Feb 2018 11:24:12 GMT
Set-Cookie
ARRAffinity=b72875202f78b3207e210dacc3385d4360e0779d57c0c23d1a3e3f5fd0a63571;Path=/;HttpOnly;Domain=sharepointonlineconnectionprovider-northeurope.db3-ase-001.p.azurewebsites.net
X-AspNet-Version
4.0.30319
X-Powered-By
ASP.NET
Content-Length
425
Content-Type
application/json; charset=utf-8
Expires
-1
Body
{
"status": 502,
"message": "Unknown Error\r\nclientRequestId: b5d75e14-82ff-4df7-9f46-8171d554ad8b\r\nserviceRequestId: ba634a9e-5022-5000-fea6-4be4bd54071b;ba634a9e-3027-5000-fea6-44d09d89ba5b",
"source": "https://'company'.sharepoint.com/sites///_api/SP.APIHubConnector.GetUpdatedListItems",
"errors": [
"-1",
"Microsoft.SharePoint.Client.UnknownError"
]
}

 

and here is it as an image...

Flow502Error.png

JenVitug
Level 8

Re: Flows stop triggering unexpectedly Bad gateway 502?

i just had this same issue for 32 of my flow runs yesterday Smiley Sad   Bad Gateway 502 ...  The Flow used to run successfully without this error.  

 

Body of Output in Bad Gateway error :

 

{
  "error": {
    "code"502,
    "source""asia-001.azure-apim.net",
    "clientRequestId""99ad0121-91b5-4483-a1cd-68b32827746b",
    "message""BadGateway",
    "innerError": {
      "status"502,
      "message""This won't work because it would move cells in a table on your worksheet.\r\nclientRequestId: 99ad0121-91b5-4483-a1cd-68b32827746b",
      "source""excelonline-ea.azconn-ea.p.azurewebsites.net"
    }  }
}

 

flow Bad Gateway 502 Error.JPG

Robin_NZ
Level: Powered On

Re: Flows stop triggering unexpectedly Bad gateway 502?

I'm having the same issue now with the Badgateway 502 error. 

 

The function is Get User Profile (V2).

 

Top of the error messages are:

  "error": {
    "code"500,
    "source""australia-001.azure-apim.net",
    "clientRequestId""c7dac170-4282-469d-bd11-fb47e264cacf",
    "message""The response is not in a JSON format.",

 

The same flow was working just a few days ago. 

 

Could it be related to a recent release?

thatOneGuy
Level: Power Up

Re: Flows stop triggering unexpectedly Bad gateway 502?

Just ran into the 502 bad gateway today as well using Azure AD - Create User. Was working yesterday

 

 

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace:

                        [NullReferenceException: Object reference not set to an instance of an object.]
                        Microsoft.Online.AggregatorService.Common.Gateway.AgsIndexConfigProvider.GetConfigVersionNumber(String configType, String configId) in d:\\bt\\932496\\repo\\src\\dev\\Common\\Gateway\\AgsIndexConfigProvider.cs:64
                        Microsoft.Online.AggregatorService.Common.Gateway.ConfigurationProvider`1.GetConfigurationImp(String identifier, Boolean useCache) in d:\\bt\\932496\\repo\\src\\dev\\Common\\Gateway\\ConfigurationProvider.cs:389
                        Microsoft.Online.AggregatorService.Common.Gateway.ConfigurationProvider`1.GetConfiguration(String identifier, Boolean useCache) in d:\\bt\\932496\\repo\\src\\dev\\Common\\Gateway\\ConfigurationProvider.cs:108
                        Microsoft.Online.AggregatorService.Common.Gateway.GlobalContext.TryGetConfigurationItem(String identifier, TConfigItem& item) in d:\\bt\\932496\\repo\\src\\dev\\Common\\Gateway\\GlobalContext.cs:324
                        Microsoft.Online.AggregatorService.Common.Gateway.GlobalContext.GetAgsRootConfig() in d:\\bt\\932496\\repo\\src\\dev\\Common\\Gateway\\GlobalContext.cs:276
                        Microsoft.Online.AggregatorService.Common.ThrottleClient.GetThrottleEndpoint() in d:\\bt\\932496\\repo\\src\\dev\\Common\\Throttling\\ThrottleClient.cs:577
                        Microsoft.Online.AggregatorService.Common.ThrottleClient.Initialize() in d:\\bt\\932496\\repo\\src\\dev\\Common\\Throttling\\ThrottleClient.cs:129
                        Microsoft.Online.AggregatorService.WebService.Global.Application_Start(Object sender, EventArgs e) in d:\\bt\\932496\\repo\\src\\dev\\WebService\\Global.asax.cs:120
                        
                        [HttpException (0x80004005): Object reference not set to an instance of an object.]
                        System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app) +535
                        System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +166
                        System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +169
                        System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +372
                        System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +329
                       
                        [HttpException (0x80004005): Object reference not set to an instance of an object.]
                        System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +525
                        System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +118
                        System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +708
VegaCTG
Level: Power Up

Re: Flows stop triggering unexpectedly Bad gateway 502?

Hi there. This seems to be a transient issue. The Azure AD connector seem to be functional now. There could have been some backend updates.

 

Wishing you the best.

JenVitug
Level 8

Re: Flows stop triggering unexpectedly Bad gateway 502?

Thanks, everything now back to normal Smiley LOL

View solution in original post

mokshich
Level: Power Up

Re: Flows stop triggering unexpectedly Bad gateway 502?

Hi, 

 

Since two weeks I am also experiencing a similar issue for one my flows. 

 

{
  "error": {
    "code"502,
    "source""flow-apim-europe-001-northeurope-01.azure-apim.net",
    "clientRequestId""4765dee8-336b-4c53-b6a5-c480bdfee705",
    "message""BadGateway",
    "innerError": {
      "status"502,
      "message""A task was canceled.",
      "source""api.connectorp.svc.ms"
    }
  }
}
 
All my other flows seem to be executing properly, this experience has started during the latest advisory for SharePoint and OneDrive for Business. 
 
 
regards,
Kamen
Brice235i
Level 8

Re: Flows stop triggering unexpectedly Bad gateway 502?

I'm getting the issue too... Update Item action.

This post is marked as solved, so probably should create a new one.

Mahavir
Level: Powered On

Re: Flows stop triggering unexpectedly Bad gateway 502?

I am facing this problem today. @ MS Flow team, any hint? resolution time ?

Mahavir
Level: Powered On

Re: Flows stop triggering unexpectedly Bad gateway 502?

Ok, in my case the 'bad gateway' error is missleading. Its basically because of the changes I made in HTTP Request action query. When I revert the change the flow works fine. So, the take away is, try reverting your recent change, if you have made any and see. 

in2217
Level 8

Re: Flows stop triggering unexpectedly Bad gateway 502?

Hi,

We just had the 502 BadGateway errorin several flows of ours. In all cases HTTP action was to call another MS Flow in the same account. It failed several times during 18 hours starting from last night and then it returned to normal without any changes made to flows.

 

Wonder how could we work around such failures. Any idea?

 

Thank you,

I.

 

vince_jennings
Level: Powered On

Re: Flows stop triggering unexpectedly Bad gateway 502?

I am getting the "BadGateway" error today.

 

The flow in question is triggered by flagging an email.

I have been using this flow for over 6 months with no problems and have not made any changes to it.

 

Is there some explanation as to why this is happening?

dar
Level: Powered On

Re: Flows stop triggering unexpectedly Bad gateway 502?

I got a 502 Bad Gateway in Flow ... in this case I was using HTTP Request action to create a site in SharePoint.  My problem ended up that I was trying to create site where there was already an existing site at the same URL.  So "Bad Gateway" not very helpful.  Must be generic error that can have many possible actual causes.  

ekongataspect
Level: Powered On

Re: Flows stop triggering unexpectedly Bad gateway 502?

This just suddenly happened this week (Oct 1 2019) again!  Does anyone have a resolution?  I have monthly workflows that run at the beginning of each month and today, they suddenly got this 'Bad Gateway' error!

Thoman
Level: Power Up

Re: Flows stop triggering unexpectedly Bad gateway 502?

Same here... started getting bad gateway error after the content was approved.

BadGateway.PNG

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020.

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Users Online
Currently online: 286 members 1,928 guests
Please welcome our newest community members: