cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SaifAli
Helper III
Helper III

Adding the attachments to Azure DevOps work item in "Create a Work item" step

Hi ,

 

Is there a way to attach a certain file from email directly to the attachments section in the User story of Azure DevOps, I'm currently having a flow that creates a work item whenever tehre is a new email but can't able to process the attachments linked to it. I need those attachments in the user story itself. Can somebody help me??

45 REPLIES 45
Anonymous
Not applicable

Hello @gyegan ,

I see the issue is with the url that you are passing in the body of the request. That should be the output of the compose you get for building the url. Ideally the compose should be “outputs(‘Compose_2’)[‘url’]. The url in the the request body should be the output of this compose step. Please let me know if you need any additional info.

Thanks for the quick response!  So the output is actually the URL I can verify  the error details.  I have attached some screen shots too.

"url":"https://dev.azure.com/myrorg/_apis/wit/attachments/d41dd813-857f-4e3c-94d4-3909860bf755?fileName=tes...",

  Screen Shot 2020-11-02 at 9.27.43 PM.pngScreen Shot 2020-11-02 at 9.27.49 PM.pngScreen Shot 2020-11-02 at 9.27.57 PM.png

Anonymous
Not applicable

“path”: “/relations/“,

 

please try this in the body where it’s “/Relations/“

No luck, i'm at my wits end!  I have created several times, made sure the msflow user is a user in AzureDevOps, tried different file types.   Is there a way to see if the file really posted? 

Screen Shot 2020-11-02 at 10.43.49 PM.png

 

Updated it so the run body was:

 

[
{
"op:"add",
“path”: “/relations/“,
"value":{
"rel":"AttachedFile",
"url":"https://dev.azure.com/myorg/_apis/wit/attachments/cd16a45a-703b-40b4-8679-69d9e61d9297?fileName=test...",
"attributes":{
"comment":"Adding attachments"
}
}
}

Screen Shot 2020-11-02 at 10.40.47 PM.png
]

If you follow your url in patch call you should be able to see and open the file uploaded in Dev Ops: 

In your case:

https://dev.azure.com/myorg/_apis/wit/attachments/cd16a45a-703b-40b4-8679-69d9e61d9297?fileName=test...

 

I would assume it is uploading, otherwise you'd get a failure earlier in the process.  That leaves the an error in your patch call where you are associating the file you just uploaded to the work item.  Your error message references a valid patch document in the body.

 

At which point I'd assume your body has an issue.  And in looking at your screen shot it looks like you are using  smart quotation marks “ instead of quotation marks " and for path and relations.

 

for reference this is what my body looks like on a process that's been running for weeks.

 

[
  {
    "op": "add",
    "path": "/relations/-",
    "value":  {
       "rel": "AttachedFile",
       "url": "https://xxx.visualstudio.com/abfdd343-a236-4a0c-a4f5-3f00b799e111/_apis/wit/attachments/a65afd28-ebff-4517-8f17-adc4f90d288c?fileName=xxx.xlsx ",
        "attributes":{
          "comment": "Added via initial email"
     }
    }
  }
]

 

See if that helps.

 

 

It was the darn quotes! I'm on a mac so that might have something to do with it. Is there a way I can buy you a cup of coffee or tea?  You just saved my sanity!  Thank you!

Anonymous
Not applicable

Hi!

 

Thanks a lot for this great guide, it has been very helpful for me. I am getting the following error in the POST action: 

InvalidTemplate. Unable to process template language expressions in action 'Post_Attachment' inputs at line '1' and column '48619': 'The template language function 'binary' was invoked with a parameter that is not valid. The value cannot be converted to the target type.'.

 

I guess it is something with the binary, though I am using it as you mentioned in the guide:

 

POST.PNG

 

 Any assistance will be very appreciated.

 

Alvaro.

Anonymous
Not applicable

@TheSwilliam 

I have setup the required steps and the attachments are saving to the Work Item however it is not saving the attachment name or extension.

 

If I download the attachment and add the appropriate extension I can open and view the data.

 

Anyone have any ideas what I'm missing here and how to pass this information as well?

Anonymous
Not applicable

Hi @Anonymous ,

 

Could you please look at my flow and tell me what caused the trouble?

 

Many Thanks!

Anonymous
Not applicable

Hi @TheSwilliam ,

 

Greetings to you!

 

I need some assistance regarding the image attachment issue you posted the resolution on.

I have just exactly followed your described ways to fix the broken image attachment problem with Azure DevOps. I mean, the image file comes in work items as corrupted on Azure DevOps.

I followed each and every step of the resolution defined here but still am failed to fetch in-body attachments (images inside the email body) to Azure DevOps work items. This is what I want to achieve below:

 

broken.png

 

This is my flow below:

 

f1.png

 

Flow segmentation below:

 

f2.png

 

f3.png

 

Could you please cross-check my flow and identify the trouble caused there?

 

Any suggestions/hints would mean a lot to me if you could assist.

 

Thanks & Regards,

Istiaq

I am trying to apply the same solution for attachments. facing an error in "Parse Json".

 

Is there any constraint related to attachment type? like it should be a text or anything?

Bansari_Pandya_0-1622120811998.png

 

Thanks in Advance!

Bansari Pandya.

 

Can you please share your work around? I also tried to upload excel or pdf. Facing error in Patch Action.

 

Thanks in Advance!

Bansari Pandya.

Hey,

 

Just wants to say thanks! same issue I am facing now it's resolved. 

 

Thanks,

Bansari Pandya.

Attachments will not show up in the description. They will be in the attachments tab in the work item. I have attached an image for reference. 

TheSwilliam_1-1625067045337.png

 

 

@TheSwilliam This helped so much!!!  Thanks for the great detailed steps!!!  Do you know how to get images in the body of the email to show up in the DevOps bug?

Hi @TheSwilliam,

 

Thanks for this solution. I have implemented the solution but I am unable to see 'url' output function to add to the 'compose 2'. Is it something that I have to manually input some where, if so where I can do that? I tried to edit the function with the following "outputs('Compose')['url']" but no luck. So just used "Outputs" function as below:

 

Bala_Ji_0-1628251928669.png

 

But below is the error message I get when the process run:

 

You must pass a valid patch document in the body of the request.
Azure DevOps ActivityId: d88ec6cb-091d-4a66-8c99-fa19f37ff6bf
Details: {"$id":"1","innerException":null,"message":"You must pass a valid patch document in the body of the request.","typeName":"Microsoft.VisualStudio.Services.Common.VssPropertyValidationException, Microsoft.VisualStudio.Services.Common","typeKey":"VssPropertyValidationException","errorCode":0,"eventId":3000}
clientRequestId: c230e3c1-3387-4d03-b28c-7e5ba9272a09

 

Any help on this is much appreciated!

Hi @TheSwilliam ,

 

I'm getting this error when posting the attachments:

 

Unable to process template language expressions in action 'Send_an_HTTP_request_to_Azure_DevOps' inputs at line '1' and column '2285': 'The template language function 'binary' was invoked with a parameter that is not valid. The value cannot be converted to the target type.'.

 

Can you please assist?

Thanks!

Az1
Regular Visitor

I am having same issue. I am unable to see 'url' output function to add to the 'compose 2'. Any luck resolving this?

Az1
Regular Visitor

Screenshot 2021-08-31 173253.png

@Bansari_Pandya i'm facing the same issue, how it get resolved?

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (2,018)