cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

Appears to be a bug with Yammer "New Message in Group" Task

There appears to be a bug in the Yammer task which is fired when a new message in a group is posted.  The flow is failing with the following message.

 

InvalidTemplate. Unable to process template language expressions for trigger 'When_there_is_a_new_message_in_a_group' at line '1' and column '5755': 'The execution of template trigger 'When_there_is_a_new_message_in_a_group' failed: the result of the evaluation of 'splitOn' expression '@triggerBody()?.messages' is of type 'Null'. The result must be a valid array.'.

 

Can anyone else confirm this is an issue?

1 ACCEPTED SOLUTION

Accepted Solutions

We have deployed the fix in all the regions. Please let me know if anyone is still having the same issue.

View solution in original post

10 REPLIES 10
Community Support
Community Support

Hi ggoodnight,

 

I’m trying to reproduce this issue on my side.


The simple flow is triggered by “Yammer – When there is a message in a group”. However, when I post a message in the group, the flow doesn’t trigger.


I will keep an eye on the flow. Not sure if there is some delay on the message sync.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mabel,

It appears to trigger, but it isn't showing up under "Run History".  The way I am able to tell that it has failed is it is showing up under "Recent Activity".

 

1.JPG

 

Clicking on it from there you can see what the real problem appears to be.

 

2.JPG

 

One thing I have tried is to set "splitOn" to off.  This causes the trigger to work, but it is causing the rest of the flow to fail because the "triggerBody" object doesn't appear to be getting set.

 

Thanks,

Grant

Still waiting on a solution to this problem.  Is anyone else having this issue?  This is very frustraiting.  This has been working fine, at least this part of it, and it has now been down for 5 days.

Hi

 

Yes I have the same issue currently.

 

The trigger error says:

 

InvalidTemplate. Unable to process template language expressions for trigger 'When_there_is_a_new_message_in_my_followed_feed' at line '1' and column '4328': 'The execution of template trigger 'When_there_is_a_new_message_in_my_followed_feed' failed: the result of the evaluation of 'splitOn' expression '@triggerBody()?['messages']' is of type 'Null'. The result must be a valid array.'.

 

 

It doesn't seem to make a difference when changing the split on button on/off. I have tried reconnecting to email and yammer. I have also tried both yammer triggers (following feed + specific group). I'm pretty sure the trigger is the problem as I tried removing the condition too.

 

Thanks

Okay so clearly this is a bug.  Perhaps @merwan or @tpalmer could help us get this resolved??

 

We now have confirmation from mulitple people this is a bug and the trigger is failing.  I tried again today to create a completly new flow and the task failed again with the same "InvalidTemplate" message.  My company uses this to link Yammer and Visual Studio for task creation, so I need to get this back to operational.

Microsoft
Microsoft

[Deleted]

Yes, we have identified the bug and we are in the process of deploying it. ETA: by 2pm PST to all regions. I will send a message again once this is deployed to all regions.

We have deployed the fix in all the regions. Please let me know if anyone is still having the same issue.

View solution in original post

This appears to have fixed the issue.  The trigger completed.  Thank you for your help!

Thanks for the fix!

This has made my day x100 better Smiley Very Happy

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Microsoft Ignite

Microsoft Power Platform: 2021 Release Wave 1 Plan

Power Platform release plan for the 2021 release wave 1 describes all new features releasing from April through September 2021.

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (17,414)