cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User
Super User

Append to Array Variable action is not working

This is not complex.  But it doesnt work.  Whats the deal?

 

Simplified for sake of example:

 

image.png

 

image.png

 

The format of the ouput is perfect.  The action lies.  Why?

 

image.png

2 ACCEPTED SOLUTIONS

Accepted Solutions
Dual Super User
Dual Super User

Re: Append to Array Variable action is not working

@martinav 

 

You would have to do a for each on the select action output as well

 

After your select action

add a loop using output from select action

and within that loop use append to array

expression for append to array would just be "item()"

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

 

 

View solution in original post

Highlighted
Super User
Super User

Re: Append to Array Variable action is not working

@RezaDorrani ,

 

I was just about to give this up...  It took me forever to get what you were trying to tell me.  I would love to know how you knew how to do this.  This is ENTIRELY non-intuitive.  Even with you explaining it, and having used ALL of these actions and commands before, it took a couple of hours to get it all together.  I have no idea how this was ever figured out.  Its almost as difficult as the first dude figured out calculus.

 

Here is what finally worked, and when I review, its exactly what you were describing.

 

Just to clarify item() is just that... item().  There is nothing in the parenthesis, as what was mentioned in an earlier post.

 

image.png

 

 

View solution in original post

13 REPLIES 13
Super User
Super User

Re: Append to Array Variable action is not working

Parsing first also fails:

 

image.png

 

Output is the same, still no go.  wtH?

 

image.png

Dual Super User
Dual Super User

Re: Append to Array Variable action is not working

Hi @martinav 

 

ECN is the part number property?

 

Your parse json will retunr an array of objects containing doc id and part number

 

In order for you to add all this data to another array

you would have to loop through each array in the parse json output

 

Apply to each - Output from parse json

and within apply to each do append to array with value "item()?['PartNumber']

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Super User
Super User

Re: Append to Array Variable action is not working

@RezaDorrani ,

 

Thanks for your reply.

 

DocumentID and PartNumber are properties of an ECN.  

 

I'm not exactly sure what you are referring too, but yes, there is an apply to each involved.  That part is not a problem.  The single task of appending the current value to the existing array is what is not working.  

 

I cannot find anything in the flow documentation regarding the Append to Array Variable action and syntax.  I did some more messing around and found that the input is wanting the values WITHOUT square brackets.  The Problem is, none of these actions make an output without them.  Seems pretty rediculous.  It seems there are different people developing actions that dont interface well together.  So the question is... how do you get parse json or a Select action without square brackets?

 

Here is my example of the only way I could get Append to Array to work:

 

image.png

TestOutput shows the desired result.

 

[
  {
    "DocumentID": 10,
    "PartNumber": "342134"
  },
  {
    "DocumentID": 20,
    "PartNumber": "475478"
  },
  {
    "DocumentID": 30,
    "PartNumber": "857412"
  }
]

 

Dual Super User
Dual Super User

Re: Append to Array Variable action is not working

Hi @martinav 

 

The select action itself gives you an array of objects

 

If you run apply to each directly on the select output

and then use append to array within the loop 

just add "item()" as expression to append to array in the loop

This should work

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Super User
Super User

Re: Append to Array Variable action is not working

@RezaDorrani ,

 

Well, i do understand what you are saying, but I'm not smart enough to get it all right.  I put Item(body('Select')) in a Compose so I could see what it is doing... or not doing, in my case.

 

image.png

 

Result:

 

image.png

Dual Super User
Dual Super User

Re: Append to Array Variable action is not working

@martinav 

 

You would have to do a for each on the select action output as well

 

After your select action

add a loop using output from select action

and within that loop use append to array

expression for append to array would just be "item()"

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

 

 

View solution in original post

Highlighted
Super User
Super User

Re: Append to Array Variable action is not working

@RezaDorrani ,

 

I was just about to give this up...  It took me forever to get what you were trying to tell me.  I would love to know how you knew how to do this.  This is ENTIRELY non-intuitive.  Even with you explaining it, and having used ALL of these actions and commands before, it took a couple of hours to get it all together.  I have no idea how this was ever figured out.  Its almost as difficult as the first dude figured out calculus.

 

Here is what finally worked, and when I review, its exactly what you were describing.

 

Just to clarify item() is just that... item().  There is nothing in the parenthesis, as what was mentioned in an earlier post.

 

image.png

 

 

View solution in original post

Dual Super User
Dual Super User

Re: Append to Array Variable action is not working

@martinav 

 

The trick is in the expressions. I have done a lot of work around expressions which has helped me get familiar with it. I almost always avoid parse json and use expressions to navigate objects which helps you to gain more insights into the way expressions work

 

Select always returns an array of objects 

In order to evaluate each object within the array we need a for loop

 

Since you needed to append each object from the array into an array variable

We used the item() property which gives the current running item in the for loop

item() property is an imp expression to know of

 

Im glad that your code worked 🙂

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

 

 

 

MarineFlow
Frequent Visitor

Re: Append to Array Variable action is not working

This has saved me, THANKS!

xbommer07
Frequent Visitor

Re: Append to Array Variable action is not working

I have this working in my flow now as well. one question. How do I format this to be a table in an approval task? 

This is what is displayed on the approval task email. 

[{"Description":"Testing Update L1","Cost":5.0},{"Description":"Testing Update L1","Cost":5.0},{"Description":"Testing L2","Cost":6.0},{"Description":"Testing L2","Cost":6.0}]

Super User
Super User

Re: Append to Array Variable action is not working

xbommer07
Frequent Visitor

Re: Append to Array Variable action is not working

@martinav 

 

Thank you for providing the link. I tried this yesterday before posting and I do not believe I understand the post on that link. The more i dig into this problem I am having I think I may have chosen the wrong approach entirely. 

 

I am using the Power Apps Expense Approval template and am trying to get the line items to show in the approval task. If you have not seen this template before it uses two sharepoint lists, one to keep the expense report (Expenses) and another to store the itemized line items (LineItems) of the expense report. 

 

I am simply trying to lookup on line items where ID on Expenses is = to ReportID on Lineitems. Then show two columns on the approval email (Description, Cost)

 

It seams adding the 2nd list as get items has complicated the entire thing more than I feel it should be. 

 

Any ideas would be appreciated. 

Super User
Super User

Re: Append to Array Variable action is not working

@xbommer07 ,

 

Oh, I totally  get it now.  In SQL lingo, you are wanting to basically to an JOIN between two tables.  This is crazy easy, but counter easy in Flow.  Look at this link.  I am doing this very thing with even three different sources.  

 

Give some love to @DeepakS for this.

 

https://powerusers.microsoft.com/t5/General-Power-Automate/Looking-for-expression-to-join-arrays/m-p...

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (6,232)