cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KUNGFUPANDA559
Helper II
Helper II

Appending Variable appending random data

I'm struggling with odd behavior. 

 

Append to array variable is appending all data being retrieved from "Get Items" action and it seems to be related to the for each that is being used.  I've created a test using flow and it works perfectliy!  My Logic app has weird data being appended when it should be the exact same experience as the test flow!  I can't for the life of me figure out why the logic app isn't functioning properly. 

 

Please Help!

 

see images below:

 

Logic App

logicapp1.png

 

logicapp2.png

This is the flow that runs properly!

 

flow1.png

flow2.png

 

 

 

 

I've built two things: 1. Flow (Testing) 2. Logic App

1 ACCEPTED SOLUTION

Accepted Solutions
KUNGFUPANDA559
Helper II
Helper II

Turns out concurrency was the problem.  Initially turned it on to see if there would be performance improvements.  I'm told by Microsoft SE that if you turn concurrency on, and turn it off, it's "still on"  I had to change concurrency settings to 1.

 

Hope this helps someone else!

View solution in original post

1 REPLY 1
KUNGFUPANDA559
Helper II
Helper II

Turns out concurrency was the problem.  Initially turned it on to see if there would be performance improvements.  I'm told by Microsoft SE that if you turn concurrency on, and turn it off, it's "still on"  I had to change concurrency settings to 1.

 

Hope this helps someone else!

View solution in original post

Helpful resources

Announcements
Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Users online (2,001)