cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper IV
Helper IV

Approval connector fails in Solution based flow

Hello all,

 

In order to use the "call a child flow" I'm being forced to work from within a Solution. When I add the action "start & wait for a Approval" I get an error message that the connection can't be made. See picture below. Doing the same outside a solution does not give the error....

 

Has anyone had the same issue, and if so, were you resolve it?

Any feedback is welcome!

 

solutionerror.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate I
Advocate I

Re: Approval connector fails in Solution based flow

Hi everyone!

I got response from Microsoft with a new suggest:

You have to create a new "Connection Reference (Preview)".

Inside your [Solution] -> [New] -> [Connection Reference (Preview)] -> Create!

Then try again create a new flow or edit one, and create an approval with this new connection.

 

Thanks to all!

@Charles-v-D Can you try this?

 

ConnApprovalsInsideSolutions.png

 

View solution in original post

18 REPLIES 18
Highlighted
Resident Rockstar
Resident Rockstar

Re: Approval connector fails in Solution based flow

@Charles-v-D 

 

I would suggest logging off and close the current browser window, clear cache and start a fresh session to check if you continue to face the same issue. 

 

If that does not work, Can you go to Data -> Connections and select and delete the current connection with Approval and come back to the Power Automate app and create a new one.

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Helper IV
Helper IV

Re: Approval connector fails in Solution based flow

@CFernandes Thanks for your quick answer! I had already tried first option: log off etc. etc... no resolution.

I had thought about the second option: remove the approval connection... But I only see one Approval connection for my entire environment.. and there are active flows using Approvals.. won't those flows "break"?

 

Regards

charles

 

Highlighted
Resident Rockstar
Resident Rockstar

Re: Approval connector fails in Solution based flow

@Charles-v-D I have seen the problem in the past and still able to reproduce it.

 

CFernandes_0-1600330135330.png

 

  • What I did was, I navigated to connection pane, +New connection, back to solution,
  • It automatically selected the connection and it worked for me.

 

CFernandes_1-1600330252860.png

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

 

Highlighted
Helper IV
Helper IV

Re: Approval connector fails in Solution based flow

@CFernandes the "issue" you show is not what I'm seeing. I don't get the screen you show where you already have to select the type of approval... before that I already get the mentioned error.

 

when you say you go to connections... that is in under DATA right? and do you first delete the existing Approval  connector? I just added a second connector, but that did not solve the problem.....

 

And if you first delete, will that break my running flows that also use that connector?

 

Regards

Charles

 

 

Highlighted
Resident Rockstar
Resident Rockstar

Re: Approval connector fails in Solution based flow

@Charles-v-D Do not delete the old connection!!

 

What you can try is, Navigate to connection, Click on +New Connection, 

CFernandes_1-1600336491498.png

 

Search for Approval and Add a new Connection. Go back to the Solution and see if that resolves the problem. 

 

CFernandes_0-1600336320702.png

 

Highlighted
Helper IV
Helper IV

Re: Approval connector fails in Solution based flow

@CFernandes 

 

Done... same issue persists 😞

 

 

Highlighted
Resident Rockstar
Resident Rockstar

Re: Approval connector fails in Solution based flow

@Charles-v-D  Ohh No.. I think we tried all the basic troubleshooting, can you open a Ticket with https://admin.powerplatform.microsoft.com/support 

 

I am sure they will be able to resolve the problem and if you get a resolution, please let me know. 

Highlighted
Helper IV
Helper IV

Re: Approval connector fails in Solution based flow

@CFernandes  Thank you trying to help me out! 

Highlighted
Advocate I
Advocate I

Re: Approval connector fails in Solution based flow

I have the same issue. I use the approvals inside solutions frequently, and this problem is new, maybe starting a few days ago. 

I test it in many tenants and get the same behavior. 

We need help from Microsoft soon!

Thanks!

Highlighted
Advocate I
Advocate I

Re: Approval connector fails in Solution based flow

Hi @Charles-v-D any update of this issue?

Could you solve it? How?

 

Thanks!

Hernan

Highlighted
Resident Rockstar
Resident Rockstar

Re: Approval connector fails in Solution based flow

@HernanRamirez Hey Mate, You might want to also raise this Microsoft Support. https://admin.powerplatform.microsoft.com/support 

Highlighted
Helper IV
Helper IV

Re: Approval connector fails in Solution based flow

already done, no feedback yet

Highlighted
Helper IV
Helper IV

Re: Approval connector fails in Solution based flow

not yet, ticker raised with MS

Highlighted
Resident Rockstar
Resident Rockstar

Re: Approval connector fails in Solution based flow

@Charles-v-D If you get an update from them, please share it with the community...

Highlighted
Regular Visitor

Re: Approval connector fails in Solution based flow

I got the same issue too.  Is there any update from Microsoft?  Thanks!

Highlighted
Advocate I
Advocate I

Re: Approval connector fails in Solution based flow

Hi everyone!

I got response from Microsoft with a new suggest:

You have to create a new "Connection Reference (Preview)".

Inside your [Solution] -> [New] -> [Connection Reference (Preview)] -> Create!

Then try again create a new flow or edit one, and create an approval with this new connection.

 

Thanks to all!

@Charles-v-D Can you try this?

 

ConnApprovalsInsideSolutions.png

 

View solution in original post

Highlighted
Helper IV
Helper IV

Re: Approval connector fails in Solution based flow

we just received the same message from Microsoft... will try tonight

Highlighted
Helper IV
Helper IV

Re: Approval connector fails in Solution based flow

@HernanRamirez initially, I was not able to selectec the Approval connector, but 24 hours later it as there. This approach works for me!

 

Thanks for all the support and suggestions!!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Users online (6,836)