cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
diegoaff92
Helper III
Helper III

Attachment with Flow from sharepoint library

Hi community

I appreciate your help, I have a problem with an attachment using flows from a sharepoint library, the problem is when I create a file, I would like to send this file as an attachment but I can't.

 

Captura2.PNG

 

First in my flow I'm asking to power apps to complete a word template and then create the file in my sharepoint library, until there everything it's ok. 

 

I have my word document with the data that I want.

 

Captura.PNG

 

Here comes the problem. When I put "When a file is created in a carpet (Cuando se crea un archivo en la carpeta)" it took long time to run it, not say that it didn't run, even I tried with "When a file is created or modified (properties only)" I have the same issue.


Hope you can help me with the answer.

 

Best regards.

 

Diego Fajardo.

4 REPLIES 4
DamoBird365
Community Champion
Community Champion

Hi @diegoaff92 

 

I think it will be because of the dynamic field you are using for the attachment name.  If you look at the history of a run and expand the history of the trigger to see the value of the field, you will be able to see if it looks like a filename.  Alternatively put the dynamic field you are using into a compose and look back at the history.

 

DamoBird365_0-1615877916171.png

 

To test, change the dynamic file to a fixed string e.g. testdoc.docx and then make sure that the dynamic field you are using is a valid filename.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Cheers,
Damien

Hi @DamoBird365,

 

Thank you for your soon reply.

 

I have this problem, when I run my flow, it works perfectly until "Create a file (Crear archivo)", then when it pass to "When a file is created in a carpet", it stuck there.

 

Captura.PNG

 

As you can see, it passed 5 minutes and it doesn't pass to my other process.

 

Do you know what could be the problem?

 

I remain attentive to your comments

 

Best regards.

 

Diego Fajardo.

Hi @diegoaff92 

 

I'm trying to understand the name of your action that is stuck. According to google translate it is:

cuando se crea un archivo en una carpeta = when creating a file in a folder

Can you please share a screenshot of the action and the data you have provided.  It looks like you have a setting for content type set to yes?

 

Also I don't quite understand how you are using what looks like a trigger condition i.e When a ... instead of an action?  A trigger requires something to happen before it proceeds, which would explain why your flow is waiting BUT I didn't think you could use a trigger within a flow so I am confused as to how you have achieved this!?

 

Anyway, if all you are trying to do is populate a word template and send an email with that file you can do the following:

Capture.PNG

 

You only need to use create file IF you want to save a copy to your SharePoint doc lib.  But you only need create file - no need for this strange when a file is created in a folder action you have found?

 

Hopefully this makes sense and gives you something to try.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Cheers,
Damien


Hi @DamoBird365,

 

Thank you for your soon reply.

 

Let me explain you.

 

First my flows dependes of my Power Apps, so in this one I click on the button "Create word template" (In Power Apps") and my flow starts. 

 

Creación.PNG

 

1. I asking to my power apps to run my flow

2. Fill out a Word Template. 


word.PNG

As you can see all my boxes fill it out with power apps.

 

3. Create File

In this section Im using a template word that is stored in my sharepoint library and create me other file but with the answer of power apps.

 

Library.PNG

This is my store of all my word templates creations.

The ID 38 (Panel.docx) its my word document base to create the other documents words.

 

 

TemplateBase.PNG

This one is my Word base to create my template.

 

FinalProduct.PNG

This one it's the final product

 

My question is, how to send this Word document as an attachment but the final product and need to be the last one that I create and save in my sharepoint library.

 

Looking forward to your answer.

 

Best regards.

 

Diego Fajardo.

 

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Users online (18,888)